PDA

View Full Version : [SOLVED] Docky stopped working properly maybe something to do with composite



thorbs
October 14th, 2010, 03:51 PM
After working well for some time, the mail app and weather app stopped working. It might have something to do with a message about docky needs composite to work properly. I am not sure what composite is though....

TeoBigusGeekus
October 14th, 2010, 06:08 PM
Open terminal and type

gconf-editor
to bring up the configuration editor.
Go to Apps>Metacity>General>Compositing Manager and turn the value to true.

thorbs
October 14th, 2010, 06:55 PM
got the editor up, found apps but there was nothing called metacity...

cariboo
October 14th, 2010, 07:14 PM
If docky works well other than the weather and mail applets not working properly, you have another problem.

Have you tried removing and re-enabling the applets?

thorbs
October 15th, 2010, 03:29 AM
Yes I tried that, but the applets does not remove complitely, settings and other things is still there when you turn it off/on. Maybe I need to completely reinstall docky. But I thought it was interesting to at least know what was happening as docky and applets was working perfectly the first couple of weeks.

zachthejones
October 15th, 2010, 03:39 AM
I'm having the same issue - the problem is compositing, whether in compiz or metacity. I had desktop effects working perfectly and then after an update all of a sudden compositing wouldn't work. And when I try to start compiz, here's the error message I get:

compiz: symbol lookup error: /usr/lib/compiz/libdecoration.so: undefined symbol: decor_property_to_quads


I had enabled the Compiz PPA, and read somewhere that might be the problem, so I disabled it, removed all the compiz packages and then reinstalled compiz - same problem.

Any ideas would be greatly appreciated...

GabrielYYZ
October 15th, 2010, 07:20 AM
try system > preferences > appearance > visual effects > normal or extra.

if visual effects are set to none, docky stops working 'cause of compositing.

thorbs
October 30th, 2010, 11:14 PM
Ok, I have identified the problem (I think).

I have had the dockey on automatic startup when the computer starts. But the problem is something to do with the lock-in. The keyring comes after the dockey program in startup. In this way somehow it does not get activated when dockey starts up.

On the other hand if I first start the computer and then manually startup Dockey the pop up with the keyring comes and after entering that dockey works fine.

I have tried to reverse the order of program start up, with out succes. Anybody have an idea of how to fix this, so Dockey can start up automatically on computer start, and the applets still work?

thorbs
November 1st, 2010, 08:38 PM
Anyone?

CoolJohnB
November 5th, 2010, 01:58 PM
You need to go to: sudo gedit usr/bin/docky and after the first line put sleep 5

I had the same problem and this solves it, everything works great.

thorbs
November 5th, 2010, 08:35 PM
Sweet, thanks

usererror
February 26th, 2011, 03:40 PM
You need to go to: sudo gedit usr/bin/docky and after the first line put sleep 5

I had the same problem and this solves it, everything works great.

That worked for me too, I just installed Docky for the first time.

webdesigncompanyla
October 17th, 2012, 11:44 AM
none of this is working for me

i just installed ubuntu 12.04.1

docky weather applet has never worked in the past either, would like to get it to work...

oldos2er
October 17th, 2012, 05:57 PM
Old thread closed.

If a post is older than a year or so and hasn't had a new reply in that time, instead of replying to it, create a new thread. In the software world, a lot can change in a very short time, and doing things this way makes it more likely that you will find the best information. You may link to the original discussion in the new thread if you think it may be helpful.