PDA

View Full Version : [ubuntu] 10.10 64bit AHCI hosed



codingismy11to7
October 13th, 2010, 08:20 PM
I upgraded my 64bit 10.04 install, and now linux refuses to boot. It can't find the hard drive, and there's what appears to be a stack trace from the kernel with lots of AHCI references. It then complains about not finding the install drive and drops to busybox.

I proceeded to download the 10.10 64bit iso, and during boot from the CD the same problem happens.

Oh, it actually looks like the problem is in modprobe. first line in Call Trace is ahci_deinit_port. after the trace it says '/sbin/modprobe -bv pci:vxxxxx' unexpected exit with status 0x0009.

This is a Dell T3500 workstation. I can't disable AHCI, since I think that will hose my Windows install.

lohith
October 16th, 2010, 07:53 AM
Dear Ubuntu Community,
I also am facing the exact same problem. The same workstation, same error and all. I am not sure if it has to do with AHCI but I have recently set up dual monitor before upgrading to 10.10.

After the unexpected exit with status 0x0009 message, it said "Gave up waiting for root device: common problems:
- Boot args (cat /proc/cmdline)
- check rootdelay = (did system wait long enough?)
- Check root = (did the system wait for the right device?)
- Missing moduloes (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/(some big name for my hard drive) does not exist. Dropping to a shell!
BusyBox v1.13.3 ...
(initramfs)


I tried to repair grub with super grub and with live CD. Both gave the exact same errors with failure to boot!

I never had this problem with any ubuntu upgrade. It seems there is not much help out there on these two error messages. I would really really appreciate any kind of guidance and help.
Waiting for the responses,
Thank you
Lohith

codingismy11to7
October 16th, 2010, 08:18 PM
just fyi, downloaded and tried the 32 bit and it acts exactly the same. live cd acts the same, can't load ahci or find the cdrom.

one post from years ago about Arch linux described a very similar error, but in that case it eventually booted. can't remember exactly, but i think it was an issue with the nvidia driver plus the ahci driver. in that post they ended up somehow blacklisting the ahci module.

mrgs
October 16th, 2010, 09:27 PM
Having so many problems on this particular hardware, wasn't it best to stick to 10.04?

nsx241
October 17th, 2010, 02:54 AM
Exact same problem. How could they have broken something as basic as ahci compatibility, and not fixed it without releasing. In any case, reverting back to ata mode fixed it for me.

lohith
October 17th, 2010, 03:47 AM
Hi all,
good news!! I figured out the solution (at least for my system).
It seems to be a problem with booting from the wrong (incompatible/faulty) kernel.
Step1:
Use the live CD. If the 10.10 does not work (as in my case) use the older ones (9.10 or 10.04). Burn a new image CD if you can. It should boot you in, with the previous default kernel for that Ubuntu version. From this, you can make modifications to the system.
Step2:
I needed to change the timeout in the /boot/grub/menu.lst to more than 0 to be able to choose which kernel I want to boot from.

For this, you need to mount the partition where you have your GRUB so you can modify files on your disk including the crucial menu.lst file. In my case it is /dev/sda5
Code:
mkdir /media/newroot
mount /dev/sda5 /media/newroot

Now you will see your hard disk mounted and you can do whatever you want with the data there. For example, in case if the data is so important, install a backup software like sbackup and backup (or at least copy) the disk to a storage media so you do not loose data.

Try step 4 directly. Use step 3 if step 4 fails.

Step 3:
In the menu.lst, check to see if you have root=uuid (long sting representing the hard disk). Change that to root=/dev/sda5 ro quiet splash (/dev/sda5 is my partition where I have my GRUB).

Step 4:
Reboot and choose to boot from the 32.25 instead of the latest 35.22 kernel. For me it was the third from the list.

You may want to change the order of kernels in the menu.lst file so the first one is the one that works.

Let me know if this solution works for you. I am curious!

Happy that two weekend late night's effort did not go in vain... Hurray! Hope my solution works for you guys too! Have a great weekend guys..

Lohith

codingismy11to7
October 19th, 2010, 05:28 PM
Never occurred to me to boot an old kernel, duh. That at least boots my system. Didn't have to change anything else, and my Grub was already set to give me the boot menu. I'm gonna comment out this new kernel in the config and hope a future update works.

codingismy11to7
October 19th, 2010, 06:40 PM
...and other problems spring up.
Upgrade removed my old kernel-headers, and I can't get them back without some level of annoyance involving old packages.
Therefore I can't install nvidia drivers straight from nvidia.
Can't use drivers from 10.10 since they require newer kernel.
Ended up disabling nouveau modesetting with a file in /etc/modules.d, and changing my xserver to use the nv driver. Have no compositing or 3d support.

codingismy11to7
October 19th, 2010, 06:53 PM
Having so many problems on this particular hardware, wasn't it best to stick to 10.04?

Perhaps, but I didn't burn an ISO, I just upgraded from my previous install. I had no idea that any of this would happen.

Tempted to reburn 04 and just reinstall, since my install was pretty recent and this isn't my primary machine - but this is definitely something that other people are going to run into.

dhavalbbhatt
October 19th, 2010, 07:45 PM
Having so many problems on this particular hardware, wasn't it best to stick to 10.04?

I don't agree with your comment. There are plenty of reasons why someone can and should try a new version of a software. There are reasons why people live on the bleeding edge of technology. Besides, have you looked at your own signature of late? Doesn't that typify the attitude of a lot of folks who use any version of Linux? Besides, that's not to say that the person who is trying a new version has ditched the older one - for all you know, they maybe just be playing with the latest version and may have run into issues using the latest version.

mrgs
October 20th, 2010, 10:11 AM
I was just pointing out that selecting a version of Ubuntu should be exactly that: A selection. There are pros and cons for every release, and jumping to the conclusion that "10.10 is best" without measuring it against the other ones can lead to a whole lot of unnecessary trouble.

Regressions do appear, and Ubuntu is no exception.

When troubleshooting, comparing to an older version is most valuable. There is a lot of experience behind 10.04.


Besides, have you looked at your own signature of late?

I have, an unfortunately I think I need to keep it like this for the next release.

mrgs
October 20th, 2010, 10:12 AM
Perhaps, but I didn't burn an ISO, I just upgraded from my previous install. I had no idea that any of this would happen.

Tempted to reburn 04 and just reinstall, since my install was pretty recent and this isn't my primary machine - but this is definitely something that other people are going to run into.

You could also try a fresh install of 10.10. As of now, we don't know whether the problems relates to the upgrade or to 10.10 itself.

codingismy11to7
October 21st, 2010, 03:51 PM
You could also try a fresh install of 10.10. As of now, we don't know whether the problems relates to the upgrade or to 10.10 itself.

No, like I've posted, I already tried this - the Live CD won't boot. The 2.6.35 kernel just plain doesn't work on this machine. The only thing that saved my install was that it WAS an upgrade, and it didn't remove my 2.6.32 kernel from 10.04.

gblues
October 21st, 2010, 09:03 PM
I encountered the same problem recently on my VirtualBox (3.2.10) running 10.10 as a guest OS.

The actual upgrade went mostly-OK, and it's actually been running since release up until this morning when I encountered the problem described in the OP. Booting to the older kernel got my VM booting again (thank you @lohith!).

jplinderman
October 22nd, 2010, 11:56 AM
Same system (Dell Precision T3500), same problem (can't boot new kernel after an upgrade from 10.4 to 10.10), same symptoms (ALERT about /dev/disk/by-uuid/... does not exist).

Here's a little more background information that may be of use to the gurus. The UUID the ALERT complains about not being able to find is, indeed, the UUID associated with my root partition, which is on /dev/sda1 (when things are working). /dev/disk/by-uuid does, itself, exist, but the sole entry after the failure is the UUID of an external drive that gets mounted on /dev/sde1 (when things are working). However, the link under /dev/disk/by-uuid for the external drive is ../../sda1. The same is true for the sole entry under /dev/disk/by-label; the label for the external drive is linked to /dev/sda1.

I'm getting along by booting the old 2.6.32-25-generic kernel, but I'd obviously prefer to keep up to date with kernel updates and have the kernel I run correspond to the Ubuntu release I have installed. If there are BIOS changes I can make to get the new kernel up and running, I'm willing to give it a try until a proper fix is found, but I'd need the BIOS-changes-for-dummies explanation of what to do. -- jpl

ScArcher2
October 29th, 2010, 08:31 PM
I also have a Dell Precision T3500 workstation and I have the same problem. (Another guy in the office also has the same workstation and problem).
We booted an older kernel as a workaround, but I'm very interested in running the latest kernel.

phireph0x
October 29th, 2010, 11:45 PM
I'd like to chime in and say that I also have the Dell Precision T3500 and am experiencing this issue after upgrading from 10.04 to 10.10. Using the old kernel provides a workaround, as described by others in this thread. Is there a plan to fix AHCI in the .35 kernel?

dksoba
October 30th, 2010, 02:06 AM
I have 2 brand new (as of yesterday) Dell Precision T3500 and having similar problem. I'll try using the old kernel and see if that works (if I can).

Matt

dksoba
November 1st, 2010, 12:47 AM
Uhhh... I'm not sure how to install the 10.04 kernel :(. I installed 10.10 via USB, not by upgrade.

Matt

mrgs
November 1st, 2010, 01:55 AM
The easiest is just to install 10.04 and stick to it for the time being.

boomertsfx
November 1st, 2010, 02:01 PM
same problem with my T3500 as well ... of course it (10.10) works fine in a VM but not on the bare T3500 :(

volleyrca
November 1st, 2010, 07:10 PM
+1 for having this problem with a T3500 and booting from older kernel as a workaround :P

Shoushin
November 3rd, 2010, 05:32 PM
I am experiencing the same error message on my MSI 790fx-gd70 based system. Ubuntu 10.10 64 bit has been my first run at using any Linux based platform, so my knowledge does have some glaring holes. I am wondering if maybe this problem is chipset specific?

My MSI 790fx-gd70 has AMD SB750 and JMicron JMB322 SATA chipsets. Currently my atempts at installing Ubuntu are residing on the AMD SB750 chipset. I will attempt the 10.04 workaround this evening. What I find odd is that Ubuntu 10.10 Live CD has no problem with AHCI. Why not just use those drivers? Let me know if additional information is required.

Shoushin
November 4th, 2010, 05:37 PM
Well, it appears the 10.04 workaround also works on my SATA chipset (AMD SB750). I am bummed about not being able to run 10.10, but at least I have some form of Ubuntu running. If there is anyone working on the problem, I have access to 5 computers that I can test on and would be happy to help out on this issue.

I hope to see us all in 10.10 land soon.

mrgs
November 4th, 2010, 08:35 PM
That's the spirit!

If there is work going on on this bug, it will be stated here:
https://bugs.launchpad.net/ubuntu
I am sure that people will appreciate some testing, when a proposed fix is released.

spirit_of_life
November 17th, 2010, 03:13 PM
I echo Volleyrca and the others:
+1 for having this problem with a T3500 and booting from older kernel as a workaround!

Is there something being done on this??

berutten
November 19th, 2010, 08:38 PM
I am also having the same problem on the T3500. It looks like there is a fix that is completed:

https://bugzilla.kernel.org/show_bug.cgi?id=16228

peterdm
November 24th, 2010, 09:35 AM
I'm experiencing the exact same problem since I upgraded to 10.10 over a month ago. An old Lucid kernel (2.6.32-25) has kept me going since then, but I can't keep that up forever. My system is a 32-bit Ubuntu on a 64-bit Dell Precision T3500 desktop.

This has been going on for over a month now, I really hope this will get fixed soon...

FYI: the new kernel (2.6.35-23) I pulled in this morning did _not_ fix the problem.

paalst
November 24th, 2010, 12:59 PM
...
FYI: the new kernel (2.6.35-23) I pulled in this morning did _not_ fix the problem.

I believe we need 2.6.37 - from the bug report:

@Bjorn: tested 2.6.37-rc1 from yesterday's Linus git repo and it works fine on my T3500 (2.6.34 to 36 had the above problems). So good fix.

kirenpillay
November 26th, 2010, 10:38 AM
I'm having the same problem on my px58D Premium board. I updated the BIOS and now on boot-up, the SATA3 disk isn't picked up. I used blkid to verify this.

This isn't a problem with the BIOS because my WIN7 installation picks up the disk fine (maybe win doesn't blow so much ;))

spirit_of_life
November 26th, 2010, 10:02 PM
I believe we need 2.6.37 - from the bug report:

@Bjorn: tested 2.6.37-rc1 from yesterday's Linus git repo and it works fine on my T3500 (2.6.34 to 36 had the above problems). So good fix.

My understanding is that the 2.6.37 is being developed for Natty (http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html) . Do we need to wait until next April to fix this issue?

weiersc
November 28th, 2010, 11:24 PM
I have been struggling with exactly the same problem on my AMD Athlon 64x2 Dual Core Processor. Spent almost all day trying to find a solution and even tried re-installing from 10.04, doing a distro update etc... just to get the same problem again. 10.10 disk does not work.

I tried to replace the UUID address with a simple /dev/sda1 , but got a further error: Target filesystem does not have requested /sbin/init. No init found.

I also downloaded the latest Natty installation disk, but it will also not boot - with the same error that I get from the 10.10 disk (Unable to find a medium containing a live file system).

I'm glad I found this thread, otherwise I was going to sleep very badly tonight :-)

bmwiedemann
December 1st, 2010, 02:18 PM
Hello

you can get 10.10 working on Dell T3500 by just adding
pci=nocrs
to your bootloader's kernel arguments.

2.6.37 will contain a code-fix which will make that work out-of-the-box, but I understand that this fix could be applied to older Linux kernels as well.

phireph0x
December 1st, 2010, 04:53 PM
Hello

you can get 10.10 working on Dell T3500 by just adding
pci=nocrs
to your bootloader's kernel arguments.

2.6.37 will contain a code-fix which will make that work out-of-the-box, but I understand that this fix could be applied to older Linux kernels as well.


I can confirm that this workaround is effective. I applied the pci=nocrs kernel boot option, and was able to boot 2.6.35-23 on my Dell Precision T3500. Thanks for the tip!

jplinderman
December 2nd, 2010, 11:49 AM
I can confirm that this workaround is effective. I applied the pci=nocrs kernel boot option, and was able to boot 2.6.35-23 on my Dell Precision T3500. Thanks for the tip!
Another satisfied customer of the proposed pci=nocrs workaround! For those (like me) who aren't familiar with grub tampering, here's what I did to make the change automatic:

sudo cp /boot/grub/grub.cfg /boot/grub/grub.cfg.orig
sudo cp /etc/default/grub /etc/default/grub.orig
sudo vi /etc/default/grub
# < # GRUB_CMDLINE_LINUX=""
# < GRUB_CMDLINE_LINUX="pci=nocrs"
# ---
# > GRUB_CMDLINE_LINUX=""
sudo update-grub

The first two lines are optional, but I knew /boot/grub/grub.cfg was going to be modified, so I made a backup to make it easy to restore, in case I did something stupid. Same thing for /etc/default/grub, which I changed directly (using vi, but pick your favorite editor). Change the GRUB_CMDLINE_LINUX variable to include the pci=nocrs fix. Then run update_grub to incorporate the change. Reboot. Enjoy 10.10. -- jpl

midden
January 21st, 2011, 10:14 PM
Thanks for the tip folks -- it works great on my Dell T3500. The added bonus is that I can finally mount an external eSATA drive now that AHCI works.

MatteoTaiana
January 28th, 2011, 08:58 PM
Thank a million bmwiedemann!
I had a stressful day trying to solve this problem on my Dell Precision T3500, with no luck, until I found your suggestion.

I just rebooted with the pci=nocrs option and it worked.

Thanks again, good job!

codecarrot
February 11th, 2011, 09:17 AM
Hi,
I have the same T3500 machine and am unable to install Ubuntu 10.10
How do I add pci=nocrs to bootloader's kernel arguments? I am unable to boot into the system itself. After the small human appears the system just reboots.
Thank you for your time.

jplinderman
May 3rd, 2011, 03:37 PM
A quick update. I upgraded to 11.04, and, with some trepidation, said to install the default grub loader when the install offered to preserve the loader with pci=nocrs. I'm pleased (but not really surprised) to say that the default loader works just fine with 11.04. It's nice to get rid of one more exception to the standard setup. -- jpl