View Full Version : [ubuntu] initramfs boot failure

October 13th, 2010, 01:39 PM
Hi all,

So my daughter says she didnt do anything but now here ubuntu wont boot up. It goes right to command line prompt and I see:

initramfs. This at the root level. Upon further investigation and an ls -l command I see many missing directories.

So, I dl 10.10 32 bit attempting a full install. It gets to the preparing for ubuntu installation and hangs there.

Any ideas how to wipe this thing clean and install?

December 22nd, 2010, 06:31 AM
I got the same error after manually (by pressing the button) rebooting while ubuntu was trying to reenter the sytem after a locked screen (sorry...2 am in the morning....not sure that made sense). I also get the initramfs command and don't know what to do, however grub works well and all, soI'm not sure what the problem is.

Anyway, if you are absolutley suire you wan't a clean install:
1. Boot from live usb/cd and open gparted (System->Administration)
2. In gparted just format/delete the ubuntu partition
3. Install ubuntu again

February 5th, 2011, 06:49 PM
I had the same trouble. What I did is insert a ubuntu live cd, boot in live session and mounting my hard drive. Once mounted I just checked in a few folders. When I restarted my system, ubuntu asked me to verify the disk / and after a few minutes of checking the system booted normally and my problem was solved.

February 5th, 2011, 06:54 PM
sudo update-initramfs -u

May 7th, 2011, 01:00 PM
You've probably fixed it by now, but for anyone else... I had the same problem, initramfs thingy, booting from usb didn't work.

Fixed it by opening grub menu (holding shift during startup) then choosing the recovery mode (there were 2 recovery modes, I chose the lower one ending in .31). It gave me the option then of fixing broken packages, which it then did automatically. It then allowed me to continue normal boot. This opened another command line screen, but with my login and password required, much like the terminal. After typing in login and password I typed "sudo reboot", entered my sudo password and everything was back to normal.

Not sure how or why this worked (as an ubuntu beginner), but hope it helps someone.


May 20th, 2011, 12:46 PM
Hopefully you might have solved by this time..!


I had the same problem with installing Ubuntu 11.04. I had already a windows 7 installed in my system and ubuntu 10.04, since i was not able to upgrade my 10.04 through network connections i planned to install it via USB disk and upgrade while installation to 11.04. but then i got initramfs error,

Before solving problem

1) I was using a Sandisk 8GB USB with U3 software on it.
2) The USB installation was created using Universal USB installer (metioned in ubtunu honepage) http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/

changes made to solve the problem

1) I used a new hp 8 GB USB drive which doesnt have U3 software
2) I created a USB installation drive on this disk using Unetbooting http://unetbootin.sourceforge.net/
Dont what solved the problem