View Full Version : [ubuntu] Web cam help

October 13th, 2010, 08:28 AM
Hi. Could you please help me. I have a Novatech V14 laptop running Ubuntu 10.10. But I can not get the web cam to work. I know the hotkey for it is fn+f10, but that does not seem to work either. It will not work on anything I try Skype, Cheese or Google chat. Thanks.

October 13th, 2010, 08:56 AM
sudo add-apt-repository ppa:libv4l
sudo apt-get update
sudo apt-get upgrade
Copy-paste that into a terminal (Applications > Accessories > Terminal). Should do the trick, but no guarantees.

October 14th, 2010, 10:05 AM
Tried this but still does not work. I installed camera monitor does not detect web cam. The cam is a bison cam nb pro. Thanks.

October 15th, 2010, 09:06 PM
put this in a terminal

lsusb click enter

that will give you the # for your cam ( or should anyway )

try the cam in cheese first 9 out of 10 that can not get a cam going try skype first

lsmod | grep video click enter

this is my lsmod | grep video

video 19856 0
output 4736 1 video
videodev 29312 1 gspca
v4l2_common 18304 1 videodev
v4l1_compat 15492 1 videodev


open a terminal type, gstreamer-properties click enter
click video try v4l1 and v4l2
click the bottom test button for each 1

cheese has a nice help file look in the faq's

hope 1 of them help

October 17th, 2010, 07:56 PM
Tried it. It brought up what you said and when I tried the gstreamer properties it did not see the web cam did not recognize dev video0. Thanks anyway.

October 24th, 2010, 10:34 AM
Here we go again. I put dmesg in a terminal and the webcam is there, but I get a "no streaming interface" message below it. Is this relevant. Thanks.

October 25th, 2010, 03:39 PM
see if this helps put this in a terminal

webcam click enter

November 2nd, 2010, 10:15 AM
Hi. I put webcam in a terminal and it came back with.
v4l2: open/dev/video0: No such file or directory.
v4l: open/dev/video0: No such file or directory.
No grabber device available.

If you could tell me what this means and what to do next I would be grateful.

November 2nd, 2010, 10:44 AM
Have you actually installed v4l and v4l2? (That's with an l for lemur NOT 1 as in 1,2,3)

Check in Synaptic to see if they are installed, and if not install them.

November 2nd, 2010, 10:58 AM
Checked the synaptic manager and yes they are there.

November 4th, 2010, 11:37 AM
Right. After spending sometime looking for a driver I found one on Sourceforge and downloaded it, which it seemed to do. But the webcam is still not being seen even in Skype. Is there something I am missing or is do I need to do anything else. Please help, getting desperate. Thanks.

November 4th, 2010, 12:23 PM
Does Cheese see the webcam now? Does gstreamer-properties?

November 4th, 2010, 03:22 PM
No, still does not see it. When I go into gstreamer-properties and test thru v4l2 and v4l it tells me that Device "/dev/video0 does not exist. I tried with turning on the webcam through fn+10 and then off again. Then Cheese just goes to a blank screen.