PDA

View Full Version : [ubuntu] ATI Radeon HD 3200, not playing HD smoothly



fremantle
October 13th, 2010, 02:01 AM
i have an acer 5532 laptop with ubuntu 10.10 64bit and ati radeon hd 3200 series driver
i used to have w7 and it played hd SMOOTHLY upto 1080p, but now in ubuntu, i cant even watch anything in 720p, not any video files OR youtube/online streams (i have a 15mbps conn).

After installing maverick, the Hardware Driver utility prompted me to install the ati driver and i did so. i also found the ati control center. But, i checked on the ati webpage and saw that they provide their own linux driver for my model. i downloaded the .run file but dont know if i should install it or not. can anyone help me>???

sk8erboi101
September 15th, 2011, 01:56 AM
Due to the incredibly suckish CPU on the Acer 5532, the laptop cannot handle the load of playing 720p videos on ubuntu. I've tested this on a dual-core laptop and it ran smoothly but not on the Acer 5532. Hope this helps.

khelben1979
September 15th, 2011, 03:04 PM
I would suggest you do a backup of your system before trying with installation of the new ATi driver, and make sure you get the right one which is suited for your Linux system.

dsp2469
April 19th, 2012, 08:06 AM
I have an HP DV5 with this graphic card.
I moved from Win 7 to Ubuntu 11 this week, and I had many problems with video reproduction, even the SD ones.
The image was ok, but no sound was coming through the HDMI port. When I changed the settings to send the sound through the HDMI, the image started going frame by frame.

I used the ATI website (support.amd.com/us/Pages/AMDSupportHub.aspx) to find the Linux driver, installed it (be careful, a restart is necessary before configuring the software) and it improved 50%.

I hear the sound in stereo (no matter if the video is 5.1 channels) and the resolution is not kept during reproduction (I lose quality). Also the frame rate is still not good.

I will keep digging, but I started thinking about buying a media center.

Conclusion: in my case the ATI driver improved my Linux installation, but I'm still far from what I had in Win 7.

mastablasta
April 19th, 2012, 08:36 AM
have you tried turning off compiz (i.e. use unity 2D)? compiz sometimes interferes with other things.

dsp2469
April 19th, 2012, 08:43 AM
How do I know if Compiz is active or not?
I don't have any fancy features, like screens on fire, or rubber screens.
By default Compiz is active or inactive after a normal installation?

Thanks in advance

mastablasta
April 19th, 2012, 09:46 AM
By default Compiz is active or inactive after a normal installation?

by deafult is active as it is used to hardware accelerate the Unity interface (i think compiz settings needs ot be installed to manipulate it via GUI). a 2D version of Unity is available where 3D acceleration is not enabled. it is ment for older mashcines or weaker GPU. but sometimes i noticed that compiz also interferes with other things. i haven't been on GNome since 10.10 (using KDE which has Kwin) but for example in 10.04 it could interfere heaviliy with a wine game i installed. the game lagged horibly until i turned compiz off. it might be worth to try to turn it off. see what happens.

dsp2469
April 22nd, 2012, 10:18 AM
You're right, mastablasta.
When I go to System Monitor or Terminal to check which processes are consuming CPU, compiz is always there, wasting up to 65% of CPU.
The problem is that, as I'm not an expert, I cannot deactivate this process, and I don't want to kill it.
So I will install the complete compiz solution, and deactivate everything.
I will post the effects afterwards.

Thanks.

dsp2469
April 30th, 2012, 08:37 AM
I tried everything I knew and all that I could find posted in this forum, and I'm said to write that I went back to Win7.
The truth is that I don't want to spend 1 or 2 months to find out how to make Ubuntu work to access Youtube and reproduce HD videos in a reasonable way.
Unfortunately I'm not ready for Ubuntu, and it is not ready for my needs.