View Full Version : [ubuntu] Theme problem after upgrade to 10.10

October 11th, 2010, 06:25 PM
Upgraded from 10.04 to 10.10 using standard Update Manager procedure. Now themes don’t work. When I change the theme, the window decorations change accordingly, but the contents of the windows (controls, panels) are in the raw X look (I don’t know how else to put it) and do not change regardless of theme selection. I’ve tried customizing the theme and selecting something different on the "Controls" tab, but it doesn’t work.

X is working properly with Nvidia driver, Compiz is working properly as well. Killing Compiz didn’t help with the theme problem.

I used 64-bit Lucid, so I guess it upgraded to 64-bit Maverick.

I would appreciate any help.

October 11th, 2010, 06:40 PM
I also have the same problem (https://bugs.launchpad.net/ubuntu/+source/ubuntu-artwork/+bug/649809).

For now, the only solution I can think of is to use nouveau. :(

October 11th, 2010, 06:52 PM
That sucks. Thanks for the reply and the workaround.

October 11th, 2010, 07:02 PM
look at errors logged , that might help

October 11th, 2010, 07:07 PM
Where, dino?

October 11th, 2010, 07:09 PM
I checked the logs (dmesg, syslog, messages) but I can't seem to find anything that is related to the theme. From what it looks, the proprietary nvidia driver does load properly, but the theme just doesn't apply correctly.

October 11th, 2010, 07:10 PM
Another double post.

October 11th, 2010, 07:11 PM
And another double post. :(

October 11th, 2010, 07:12 PM
Sorry, double post.

October 11th, 2010, 08:01 PM
I found a temporary fix: http://ubuntuforums.org/showpost.php?p=9932580&postcount=20

October 11th, 2010, 08:32 PM
Nice find, but it’s a weak consolation for me. I can’t get my theme right with this fix either.

Did you upgrade to 10.10 or was it a clean install? This is so bad that I consider reinstalling from scratch. But it’s not easy and I have no assurance that it would solve the problem.

October 12th, 2010, 10:17 AM
I did an upgrade. It really isn't an overall fix. And I don't like to do a clean install. I guess I just have to wait for a proper fix to come.

October 15th, 2010, 01:38 AM
I just did a clean install of 10.10 amd64 desktop on an Asus G73JW laptop computer - same theme problem here - window decorations are working but the panels and in-window controls all remain at gnome default looks. This behavior started at the very first boot, after installing the nVidia driver the behavior remained unchanged.

October 15th, 2010, 01:45 AM
If you have a Launchpad account, please go to the ticket for this bug and click on the "Does this bug affect you?" link. With a larger number of affected users, it's more likely that we will get help. Here's the ticket page:


On that page, you can also find workarounds from other users and keep up with the progress, if there will be any.

January 15th, 2011, 07:19 PM
For now, the only solution I can think of is to use nouveau. :(

Find that hard to believe since i have the same problem on a computer without nVidia, ASUS U31F (http://www.asus.com/product.aspx?P_ID=OV45sT3DY56akobY).

January 15th, 2011, 07:27 PM
For now, the only solution I can think of is to use nouveau. :(

Find that hard to believe since i have the same problem on a computer without nVidia, ASUS U31F (http://www.asus.com/product.aspx?P_ID=OV45sT3DY56akobY).

January 20th, 2011, 10:24 AM
I also have this problem.

#70 in the bug report fixed link fixed it for me

until reboot

#68 fixed it

must be something with the SSD

December 13th, 2011, 04:05 AM
Hi everyone,

I wrote a little script to open gnome-appearance-properties, which changes the theme to your preferred one, then kill nautilus, and finally if errors didn't kill gnome-appearance-properties, the final step will.

I have an i7 with and SSD so, adjust the sleep times to suit your comp. This problem plagued me after installing the nvidia driver shortly after a clean install.

I named the file /home/themesfix.sh and opened system >> preferences >> startup applications and added the command /home/themesfix.sh to that list.


# Scripting to delay on start and then run
sleep 2
gnome-appearance-properties --g-fatal-warnings
sleep 2
killall nautilus
#sleep 2
#killall -w gnome-appearance-properties

# done

On my setup, the gnome-appearance-properties opens with 3 errors, so the --g-fatal-warnings cause it to close, but it still does its thing.

Anyways, I hope this helps someone out there with this frustrating problem.