View Full Version : [ubuntu] Will only boot to grub rescue when I upgraded (wubi installed) 10.04 to 10.10.

October 11th, 2010, 05:34 PM
Installed Ubuntu 10.04 a week ago or so (using wubi.)
Tried to upgrade to 10.10 from within Ubuntu using the update manager.
Now the PC will only boot to grub rescue.

When booting, this is what i get:
error: no such device: cd200414-0606-4d7d-8c08-004e9b5dc92d.
grub rescue>

Three commands work: ls, set and insmod.
The ls command only yields: (hd0)
(no partitions like (hd0,1), (hd0,5), etc.)

I have no idea what to do... Any help would be greatly appreciated!

(Using an Asus UL30A without optical drive. Have managed to create a Live USB, which I'm currently using.)

October 11th, 2010, 05:42 PM
I think answer #4 at this similar thread may help you:


October 11th, 2010, 06:09 PM
Thanks! This solved my issue.

In short, this is what was recommended:

Boot using an Ubuntu Live CD or USB.
Open command shell.
Enter: sudo apt-get install lilo
Enter: sudo lilo -M /dev/sda mbr
Reboot. The windows boot loader should now be restored.

October 11th, 2010, 08:20 PM
You're welcome, glad it worked.

October 11th, 2010, 08:57 PM
I have similar problem, but my error says ELF header smaller than expect. anyone knows what I could do? I don't want to lose all data on my disk..