View Full Version : [all variants] 10.10 installation went terrible wrong - Bad magic number in super-block

October 11th, 2010, 04:28 AM

I tried to do a fresh install of Maverick on my computer. For some reason the GUI never started and I ended up with a black screen. I restarted my PC and I got an error on one of my hard drives.

I searched the internet and followed guides on how to fix this issue but nothing have worked.

I ran:
mke2fs -n /dev/sdc2

I tried all the block numbers that it returned. Still fails with the same error "fsck ext3 Bad magic number in super-block while trying to open..."
e2fsck -b 8193 /dev/sdc2

I'm on windows right now using a recovery software but it doesn't seem to be able to recover my data.

Please help

October 13th, 2010, 11:03 AM
If you installed with your external hdd connected, please disconnect it and try again, post results.

It may be due to misconfiguration in fstab or an udma problem as some user have reported.

Maybe you can get to login screen if you click "s"

October 25th, 2010, 04:45 AM
I was able to recover most of my data using recovery software. I still can't install meerkat because I think I have a problem with the new kernel and nvidia graphics :(

I'll probably wait a couple of months and try again to upgrade to the newest distro.

Thank you :)