PDA

View Full Version : [SOLVED] Interrupted dpkg run



gerrymike
October 10th, 2010, 07:23 PM
Hi all!
From the Ubuntu repository I downloaded upgrades for my installed software. While dpkg was installing these there was an electrical storm & a power cut. Now I cannot install or remove any software.
I am prompted to run a partial upgrade followed by: sudo apt-get install- f.
On running Synaptic Package Manager I am instructed to enter command: sudo dpkg --configure -a.

This results in the message that file: /var/lib/dpkg/updates/0183 has a parse error near line 0 in that ;, should be followed by a colon.
I have tried to edit this file using VI (VIM) but, not being proficient with this, I am wary of doing further damage.
I would be most grateful for advice & help.
Regards,
Gerard

dino99
October 10th, 2010, 07:30 PM
well if you have not a package error name, you need to download again

sudo rm -f /var/lib/dpkg/updates/*

gerrymike
October 10th, 2010, 10:32 PM
The suggested fix has worked perfectly, many thanks,
Gerard

mrgs
October 10th, 2010, 10:40 PM
Good, please mark the thread 'solved'.