View Full Version : [SOLVED] "Allocate drive space" blank

October 10th, 2010, 02:44 PM
Hi folks, I've been dual booting into Ubuntu and Windows 7 for a while. I broke my 10.4 installation trying to "update-manager -d" to the 10.10 beta. I just burned the ISO for my system, booted from CD, and used GParted to erase the bad installation.

I want to install Ubuntu 10.10 here (vanilla, no screwing around with a separate /home partition):


I go to install and get this at the "Allocate drive space" window:


What am I doing wrong and how do I fix it?

Thank you.

October 10th, 2010, 03:09 PM
I've been dual booting ... used GParted to erase the bad installation

#-o Don't do this. Now I deleted grub and can't go back into Windows. What a stupid mistake...

Also, EMR (http://ubuntuforums.org/showthread.php?t=1591685) and I seem to be having a similar problem.

sudo fdisk -lu:

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1549f232

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 206848 1021460894 510627023+ 7 HPFS/NTFS
/dev/sda3 1226260480 1249996799 11868160 7 HPFS/NTFS

October 10th, 2010, 03:14 PM
Your partition table looks OK to me. I'm not sure what the problem is at this point.

October 10th, 2010, 03:33 PM
In the meantime, how do I make Windows bootable again? If I were to restart I would get a black screen and a prompt saying something like:

That partition does not exist
grub rescue>_

Edit: This is blasphemy, and I intend to re-install, but this is good information:

Mark Phelps
October 11th, 2010, 03:34 PM
When you were in Win7, did you use the Backup feature to create and burn an Win7 Repair CD? Don't need to answer that ... no-one does that.

So, go to the link below, download the proper Win7 Repair CD image, burn that to CD, boot from that CD, and run Startup Rpair three times -- yes, that's three times!


That should get you back into being able to boot into Win7.

October 18th, 2010, 02:32 AM
Sorry for the delayed response.

I was able to get back into Windows 7 after using a repair CD. I used wubi, restarted when prompted, and got this:


Clicking "OK" just brings up the same error message. Should I use GParted on a regular Ubuntu install CD?

October 23rd, 2010, 01:57 PM
This solution worked for me!