PDA

View Full Version : [ubuntu] Severe download slowdown with K3565 - V2 3G Modem



Nightstrike2009
October 9th, 2010, 02:01 PM
Hiya everyone,

I am experiencing problems with my Vodafone 3G modem it functions well with Ubuntu 10.04 but some times I get "Download rate: Unknown" messages and downloading seems to hang up.

Ive asked a mate who thinks it is down to 3G networks, it makes it hard to download updates 1st time any ideas on how to get around this?

Nightstrike2009
October 9th, 2010, 02:43 PM
Ive noticed that enabling http://archive.canonical.com/ubuntu lucid partner makes a difference in "software sources" otherwise the only solution I have found is to download the problem packages manually via "Ubuntu Packages/Lucid" and install via deb.

Nightstrike2009
October 9th, 2010, 04:54 PM
Well ive got around my problem by manually downloading problem packages and installing via deb but iam sure its supposed to be easier thatn this just to use update-manager with a 3g modem surely?

alexfish
October 9th, 2010, 06:18 PM
Hi

try edit the ppp options /etc/ppp/options

to enable ip forwarding add this line

ktune

remove the # from the #-vj

to look like

-vj

change values of lcp-echo-failure and lcp-echo-interval

lcp-echo-failure 0
lcp-echo-interval 0

see what happens

alexfish

Nightstrike2009
October 12th, 2010, 11:47 AM
Hiya alexfish didn't fully understand that

I entered code:

gksudo nautilus

Navigated "Filesystem" to /etc/ppp/options

then got lost has to what to do next, could you please point me in the right direction, thanks.

My update manager is refusing to install "libc" updates, "xulrunner" and "erlang" updates (download speed becomes "unknown" and doesn't respond) all others it has accepted ok (or has after some forced via manual deb downloads)

I have gone to System>Administration>Software Sources and under Ubuntu tab:

Select Download from to "other"
"Select Best Server"
And gone with highlighted server option as UK server wasn't the best, however the same problems persist.

alexfish
October 13th, 2010, 02:47 AM
hi

try this way

sudo gedit /etc/ppp/options