View Full Version : [ubuntu] Ubuntu will not detect wireless networks whatsoever

October 3rd, 2010, 01:20 AM
I just downloaded and installed ubuntu netbook 10.4 on my samsung n130 netbook...love it, except for one little thing: it won't detect any wireless networks. this is how i connect to the internet at home so using an ethernet cable is not an option...
i tried putting in "ifconfig wlan0 up" in the terminal, but all it gives me is "permission denied"..
i looked at previous threads on the subject and couldn't find anything that could solve my situation. Please help me out, i want to make the total switch from windows to ubuntu and i'd really like to be able to fully use it...
thanks a lot

October 3rd, 2010, 01:33 AM
i tried putting in "ifconfig wlan0 up" in the terminal, but all it gives me is "permission denied"..

start your command line with 'sudo' followed by your command

e.g. 'sudo ifconfig wlan0 up'

October 3rd, 2010, 03:23 AM
yeah you need "sudo"
although i would guess it would already be up..

have you tried running this off a live cd first to see if wireless was working?
also ifconfig by itself should show wlan0 and the hardware address.

also quite a few other things that can be tried if these fail..

sudo nano /var/lib/NetworkManager/NetworkManager.state

and check to see if they are all true

October 3rd, 2010, 05:07 AM

This thread might help, Good Luck.

October 3rd, 2010, 08:47 PM
alright, i got it to work by downloading and installing the realtek driver, although it's still not working very well. i cannot load pages on firefox or chromium half the time, same when i try to download updates for ubuntu... and i keep losing connection to my wireless network (have to restart the computer to get it back)...
help? :-/