PDA

View Full Version : [all variants] RAID 0 crashed by dmraid(?)



SiViS
September 30th, 2010, 10:59 PM
Hello there, strangers. I wanted to describe my little problem and ask for help, if you can provide some.

So, when I was happy, when my system worked as always, with little annoying errors here and there, I decided to finally install Ubuntu. So, I've got 4 hard drives. Two 1Tb (Ex)-RAID 0 drives, one 1Tb with 3 partitions, and one for 600 gb. Controller is ICH10R. So, let's name my system partitions on second drive C and U. On C there is Win 7(for 4 months now) and on U I installed Ubuntu (10.04, 86_64). Install went smooth, system worked, awesome.

Than I decided to use RAID in Ubuntu. I installed dmraid and set dmraid -ay as start up command. Problem is, when I next booted in windows it refused to see RAID and showed me my two drives instead. I decided to try to recover my RAID. Installed Diskinternals "RAID Recovery" and after 5 hours of waiting it reports me that I must buy this piece of... code in order to be able to recover the RAID. I damned this and rebooted to Ubuntu. Next time i was logined in windows I was amazed. It showed me my RAID.

Ok, after next reboot sequence the other day, I found myself with disabled RAID once again. All this time in Ubuntu RAID was working perfectly. So, as you may guess, the question is "What the hell? What should i do to live with my RAID happily?" :(

p.s. Thanks in advance.
p.p.s. Sorry for my English.

SiViS
October 1st, 2010, 07:44 AM
Anyone? bump.