PDA

View Full Version : [ubuntu] Troubles with D-Link DWA-140



wolfgan
September 25th, 2010, 06:53 AM
OS Ubuntu 10.4

I have installed DWA driver as recomended there: http://http://sudosys.be/?q=D-Link_DWA_140_ubuntu (http://http//sudosys.be/?q=D-Link_DWA_140_ubuntu)
Before that I was done
sudo rmmod rt2800usb rt2x00usb rt2x00lib
sudo gedit /etc/modprobe.d/blacklist.conf
blacklist rt2800usb
blacklist rt2x00usb
blacklist rt2x00lib
Now I have

lsmod | grep rt
rt2870sta 557965 0
and iwconfig returns


lo no wireless extensions.
eth0 no wireless extensions.
pan0 no wireless extensions.
How can I get it up?

davedub
September 25th, 2010, 11:06 AM
Exactly same here - I'm very new to linux, so please bear with me. It seems to me that my rt2870sta driver is present, the necessary (i.e confilicting) drivers are blacklisted as per other forum posts, but there is still no wireless interface is available / detectable.

This issue seems to have been going on a long time, with most ppl applying the above workaround - but it hasn't worked for me either.

Any help? Please?

- Davedub

Mattias
September 25th, 2010, 12:16 PM
A me too here, Something is fishy with the current state of drivers.
//Mattias

claypole
October 4th, 2010, 07:07 PM
Try here... http://ubuntuforums.org/showthread.php?t=1449781 :)