View Full Version : [ubuntu] Ubuntu 64 no Java Firefox plugin

September 24th, 2010, 11:34 PM
Ubuntu Desktop 10.04 64 no Java Firefox plugin

sudo apt-get install sun-java6-plugin


Couldn't find package sun-java6-plugin


September 25th, 2010, 12:00 AM
I believe you have to enable the Partner repos in System > Admin > Software Sources > Other Software and reload and then try the command.....

September 25th, 2010, 12:10 AM
Thank you this works...

1. Enable repository: Click System -> Administration -> Software Sources, go to tab Other Software and tick the first entry ("partner"). Close and confirm the "Reload".
2. Install Sun Java: Go to Applications -> Software-Center -> Search for "sun java" and install the first package ("Sun Java 6.0 Plugin"). You are done!

Someone needs to update the help file in ubuntu with this info. :popcorn:

September 29th, 2010, 05:06 PM
Is that version actually working for you?

I installed it and then done tests (using both firefox and chromium) at


These told me all was okay and I was using:

Vendor: Sun Microsystems Inc.
Version: Java 6 Update 18
Operating System: Linux 2.6.32-25-generic
Architecture: amd64

All good so far. However when I try other sites like, say:

all I get is a gray box

and on firefox
Start: applet not initialized in the bottom corner of firefox.

October 25th, 2010, 09:38 PM
I worked out my problem. It seems the icetea and java plugins were not playing together nicely.

I removed all the icetea stuff and now it seems all good.

October 26th, 2010, 11:09 AM
I use on-line money transfers and the screen I use has Java applets.

Every time I update Ubuntu to the latest release the Java applet stops working - so I do not update Ubuntu on each release. Currently I am on 10.04.

BUT - although I always delete any Icedtea software through the Synaptic Package Manager, this time the Java applet still does not work. The required form appears for a few seconds then disappears!

I wonder if anyone else has a similar problem?

I am using a PackardBell laptop with 2 AMD Turion 64 processors and Ubuntu 10.04.

October 27th, 2010, 04:50 PM
Silly question this but have you tried removing all Java then reinstalling.