PDA

View Full Version : [SOLVED] 10.04 server + Squid3 config problem



Es-trumpfe
September 21st, 2010, 06:58 PM
Hello.

I'm trying to configure Ubuntu server 10.04 with Squid3. I've followed this tutorial (http://www.ubuntugeek.com/setting-up-ubuntu-10-04-lucid-server-with-squid-3-as-a-transparent-proxy.html), making corrections only to the network addresses. So far, I've faced the following problems, which keep bugging me:

- If I connect the router directly to eth1, I cannot ping the proxy (probably due to hosts configuration on the client machine)
- If I connect the router through the switch, I can ping the proxy and, after configuring the client machine with the proxy settings (with the proxy as gateway), I get squid to report error "101 - network is unreachable" (error configuring packet forwarding?!)

However, now I keep getting errors when activating eth0:



sudo /etc/init.d/networking restart
* Reconfiguring network interfaces...
SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Failed to bring up eth0
Which, after a little search...



dmesg | grep -i eth0
[ 1.153766] eth0: Tigon3 [partno(BCM95721) rev 4101] (PCI Express) MAC address 00:13:21:cc:39:9b
[ 1.153772] eth0: attached PHY is 5750 (10/100/1000Base-T Ethernet) (WireSpeed[1])
[ 1.153775] eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
[ 1.153779] eth0: dma_rwctrl[76180000] dma_mask[64-bit]
[ 4.985380] udev: renamed network interface eth0 to eth1
And I'm stuck here. I've attached the interfaces and squid.conf files hoping it will help with your suggestions.

Thank you.

koenn
September 25th, 2010, 08:06 PM
[ 4.985380] udev: renamed network interface eth0 to eth1

don't know why udev decided to do that (maybe you've been messing with hardware or VMware settings ?), but anyway :

you don't have eth0; you do have eth1

modify /etc/network/interfaces accordingly, i.e. set a config for eth1
check the other config files (squid, iptables rules, ..) for references to eth0, replace by eth1

restart networking

see what gives

Es-trumpfe
September 30th, 2010, 05:15 PM
Well, somehow, the first adapter came back to life on its own, so everything ok on that. The squid routing problem was also solved (added port 80 on the accept list). Everything's working now.

Thank you.
Cheers.

Vishal Agarwal
October 2nd, 2010, 06:59 AM
#ifconfig eth0 up should bring up the eth0