View Full Version : [ubuntu] Hanging after first reboot

September 20th, 2010, 05:52 AM
Hello all,

There's a strange problem, after installing ubuntu 10.04.1 using wubi.

The installation goes fine in Windows, unpacks to an empty 15gb ntfs partition. After restarting to complete the installation, it would'n find the grldr but fixed that by copying over the wubi* files installed in C:.

Now the problem, the boot screen shows for a few seconds, switches to the default ubuntu wallpaper, the mouse cursor is there and working, and that's it. The installation doesn't continue, the keyboard won't work; Also I've tried all the additional options the installation offers when it asks to press Esc.

The system:
Wubi installed size: 15gb
32bit Ubuntu 10.04.1
4gb installed ram
nVidia 9800gx2

Using ubuntu for a month on my netbook determined me to add it to my desktop so I hope this gets fixed :popcorn:


September 20th, 2010, 06:03 AM
With 10.04 and nvidia there have been some problems. The way to get around it is to supply "nomodeset" as a boot option. When installing with wubi the ESC option doesn't give you an entry that includes this. Just press ESC, then 'e' on any of the options and within the big mess you find, look for 'quiet splash' then add 'nomodeset' after that i.e. 'quiet splash nomodeset' without the quotes - then CTRL+X to boot.

You will have to do this every time you boot until you can get the correct nvidia driver installed. If you want to you can edit /etc/default/grub and set it there in GRUB_CMDLINE_LINUX_DEFAULT

gksu gedit /etc/default/grub
# modify the cmdline default
sudo update-grub

September 20th, 2010, 06:41 AM
That wasn't it. The system simply hangs showing the boot screen this time. 'noprompt' was in front of 'quiet splash' if it means anything...

P.s. Live cd has the same problem as in my first post.

September 20th, 2010, 03:12 PM
what computer brand/model is it?

September 20th, 2010, 04:46 PM
It's not a pre-assembled. Here are the specs

Manufacturer:Gigabyte Technology Co., Ltd.
Processor:Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz (2 CPUs), ~2.9GHz
Memory:4096MB RAM
Hard Drive:2 TB Total
Video Card:NVIDIA GeForce 9800 GX2
Monitors:Samsung SyncMaster 226bw - BENQ FP71G
Sound Card:Sound Blaster X-Fi Xtreme Audio
Speakers/Headphones:Logitech G51
Keyboard:Logitech G25
Mouse:Razer Mamba
Mouse Surface:
Operating System:Windows 7 Ultimate 32-bit
Motherboard:Gigabyte EP31-DS3L
Computer Case:NZXT Tempest

( yes... I'm a gamer :/ )

September 20th, 2010, 07:22 PM
I can't see anything that should cause you problems other than nvidia, but the workaround should have taken care of that. Not sure why you are using wubi with all that disk space (as you likely have no problems partitioning). If you decided to try a direct install you could use the Alternate CD instead - it has more advanced installation options and *might* do a better job.

September 20th, 2010, 09:00 PM
I'll give that a shot then. I'm quite-tech savvy and realize that shouldn't interfere with the first OS, being on another partition.

But I've had a lot of 'Murphy's law' situations lately, that's why I've used wubi; because it seemed safest, until I figure out how and what happens with the mbr and grub and windows' loader.. meh.


Installed from the alternate cd (note: on logical partition), I can reach the login screen, enter the password, then it's back to problem #1,
When trying to use nomodeset, the screen just freezes at the ubuntu boot screen, as before.

Tried entering a tty while at the login screen, the display just shows the residual image of the login screen..

So... yeah :?

I'm able to log into xterm, so I'm not completely locked out. Seems there might be a gnomey problem....

September 21st, 2010, 11:44 PM
Bump. 'cause editing won't bump it :/

Edit: Solved, I think. Purging everything nvidia from xterm and rebooting seemed to do the trick.

... :D