View Full Version : [all variants] Cannot configure GRUB properly

September 18th, 2010, 06:02 PM
Hi, i've just installed Lubuntu but i didn't want to install the GRUB bootloader in MBR. I tried to install on the same partion of Lubuntu but the option cannot be completed (mistery). I could only install grub on MBR or on my Windows partition (!) , so i chose not to install it. Then using Puppy linux live cd i installed grub on sda2 (Lubuntu one), added Lubuntu to the list
I used Puppy linux because it had the possibility to install grub, while in Lubuntu there's no such option in the livecd

Then i flagged the sda2 partion as "boot" and restarted and then grub came up correctly. But when i select Lubuntu it says "file not found" error 15. I searched a bit on this forum, but all the information in my menu.lst seem correct to me. I've tried changing the numbers playing with hd0, 1 2 ec... but i'm quite sure that hd0, 1 is right

Here's my configuration:
ONE harddisk with three primary partions ->>
sda1 -> windows 2000
sda2 -> Lubuntu
sda3 -> Swap

searching i found that it might be a problem with grub not loading the kernel, vmlinuz stuff ecc... but i can't understand much.

I come from Puppy and i used to install grub in the MBR but this time i want to install it in the linux lubuntu partition flagged with the "boot" option.
I'm quite new in Linux world

Any help is appreciated,
if you need i'm gonna post the content of my menu.lst file. Just give me a minute.
here's the content of menu.lst ->>

# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Sat Sep 18 19:18:59 2010
# Start GRUB global section
#timeout 30
color light-gray/blue black/light-gray
# End GRUB global section
# Linux bootable partition config begins
title Lubuntt (on /dev/sda2)
root (hd0,1)
kernel /boot/vmlinuz root=UUID=17b4e8d8-1bbe-4419-987f-2d4ee89cfc09 ro vga=normal
# Linux bootable partition config ends
title Install GRUB to floppy disk (on /dev/fd0)
pause Insert a formatted floppy disk and press enter.
root (hd0,1)
setup (fd0)
pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/sda2)
root (hd0,1)
setup (hd0,1)
pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)

September 18th, 2010, 07:06 PM
There is more than one part to grub, the "boot loader" (which has limited space in mbr or beginning of partition) and "everything else" in /boot/grub, including additional stages, modules, and menu. There are also 2 major grub versions, the original (legacy) grub with a version less than one, and grub 1.96 or 1.98 often referred to as grub2.

You didn't say which Lubuntu version, but if it is a recent version it would use grub2 by default. You should not have had a problem installing grub2 to sda2 if you ignored the warnings, but you ended up not installing any grub at all.

So now you installed the legacy grub boot loader on sda2, but it has nowhere to go for the rest of its files because there is no /boot/grub on sda2.

Simplest would be to reinstall Lubuntu using the manual partitioning to select the partition you already installed it on. Then use the Advanced button in the last stage to put grub on /dev/sda2. Just ignore the warnings that it might not work there. I have never had any trouble putting grub on a primary partition using dos/win mbr, as long as you know that you need to mark that as the boot partition.

There are other ways, but that is more complicated when you do not even have grub installed in the Lubuntu system.

September 19th, 2010, 10:11 AM
eventually i solved reinstalling Lubuntu over the previous one: this time the option to put GRUB on sda2 was available maybe because the partition was already formatted with ext3 filesystem (?)

Thank you for the explanation, i will keep in mind for the future