View Full Version : [SOLVED] sun-java6-plugin displayed in Firefox 3.6.10 but not working

September 17th, 2010, 11:16 AM
Initially when I upgraded to Lucid I uninstalled openJDK and switched back to sun-java5 packages due to some application support limitations.

Now I have to upgrade to sun-java6- packages. I removed the sun-java5 packages and installed the sun-java6 packages. Including the sun-java6-plugin.

I can see the plugin in about:plugins in Firefox 3.6.10 however nothing (like webex or applets) related to java works.

As a workaround I have used the Icedtea plugin which comes with open JDK and that seems to work. However I want to get the sun-java6-plugin working.

Any pointers?

September 17th, 2010, 12:41 PM
Maybe this: Choosing the default Java to use (https://help.ubuntu.com/community/Java#Choosing%20the%20default%20Java%20to%20use)

September 20th, 2010, 06:01 AM
Thanks for the link but I have done that already. I don't have Open JDK installed so there is no switching required.

Either way java -version prints out the Sun JDK version.

I am hoping that the upgrade to 10.10 might solve it.

September 20th, 2010, 06:23 AM
You can find some useful information in this link: http://sites.google.com/site/easylinuxtipsproject/java#TOC-HOW-TO-FOR-32-BIT-UBUNTU

September 20th, 2010, 04:33 PM
Ok I found out the problem. Apparently Compiz had a problem displaying java applications with Java 5. I had used a workaround to export MToolkit as the default toolkit.

Removing that line from my /etc/environment solves this issue.