View Full Version : [SOLVED] installation of ubuntu 64bit server fails - cannot install base system

September 8th, 2010, 10:45 PM
Hi folks,

i have installed a ubuntu a few times using different versions and hardware.

but this is a first for me.

while installing ubuntu server on a machine that used to run ubuntu hardy (just tried CentOS), i get error as below>

!! install the base system
cannot install base system
the installer cannot figure out how to install the base system. no installable CD-Rom was found and no valid mirror was configured.

*however* i have test the CD on this machine and it passed

i also burned 3 other CDs and all fail.

i am installing on LVM-root but it was working fine on Hardy before

while the installer is running - on a second ternminal if i try

ls -l /cdrom/*

i get errors such as:

ls: /cdrom/ubuntu/doc: Input/output error

any idea on what i can do?

many thanks,


September 8th, 2010, 10:56 PM
just a quick update on my problem.

i tried to

umount /cdrom
mount /dev/cdrom /cdrom

and it seems to have fixed the problem.

as for what the problem was *NO* idea.

hope this helps someone.
or at least myself if i ever find this problem again.


September 17th, 2010, 07:30 AM
unmounting and mounting the cdrom did the trick for me as well. Only i couldnt mount it in the same way as nicolasdiogo. I needed to do this:

umount /cdrom
mount /dev/disk/disk-by-id/<cdrom name>