PDA

View Full Version : [SOLVED] Ubuntu won't boot after changing xorg.conf



GROwen
September 8th, 2010, 04:26 AM
Hi all,

I changed my xorg.conf file to see if the nVidea graphics card I'm using supports coolbits and after restarting gdm my installation won't boot past the Ubuntu splash screen, the one with the circles underneath Ubuntu (I have auto login).

I'm running 10.04.

Thanks in advance for any help that can be offered.

wojox
September 8th, 2010, 04:46 AM
Reboot and after the BIOS screen hold down the left <Shift> key and choose recovery mode. There should be an option about failsafe X.

If that doesn't work drop into a root shell and run


nvidia-xconfig

JBAlaska
September 8th, 2010, 04:51 AM
And if that does not work, rename xorg.conf xorg.old and restart

GROwen
September 8th, 2010, 05:46 AM
Cool, thanks for the tips guys.

wojox
September 8th, 2010, 11:54 AM
Did any of the tips work?

If so you you state which one and mark as solved for the next individual who comes along with the same question.

VanillaMozilla
September 8th, 2010, 11:35 PM
The other way is to boot in recovery mode. That will get you a command line. Rename xorg.conf xorg.conf.sav or something like that. Then the old file will still be there. I forget what it's called, maybe xorg.conf~ . (I forget some details--I'm on Windows at the moment.)

So typical commands would be

cd /etc (or whatever the directory name is -- I forget)
mv xorg.conf xorg.conf.sav
mv xorg.conf~ xorg.conf

Then reboot and you're on your way. You could also edit the file, but:
(1) be sure to copy the existing backup file to another file name (so you don't lose it forever).
(2) You'll need a command-line editor. vi is usually used. Good luck.