PDA

View Full Version : [ubuntu] 64 bit 10.04 wireless not working



craigmarti
September 4th, 2010, 05:12 PM
Hi all,
I just did a fresh install of 10.04 and I cannot seem to get my wireless working. My previous install was 8.10 and the wireless worked fine there. I decided to do a fresh install to switch from 32 bit to 64 bit. I don't remember having much issues with my wireless when I installed 8.10.

My wireless card is:
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)

I have tried numerous drivers to install and no luck yet.

The furthest I have made it is by attempting to install the e1000e driver. I get to step 6 of the instructions and I get the error:

craig@craig-laptop:~/drivers/e1000e-1.2.10/src$ sudo ifconfig eth1 192.168.1.5
SIOCSIFADDR: No such device
eth1: ERROR while getting interface flags: No such device

Below are the instructions that I followed. Any help would be appreciated. I really want to avoid going back to 8.04 32 bit or even worse go to MS. Thank you in advance.

Craig


1. Move the base driver tar file to the directory of your choice. For
example, use /home/username/e1000e or /usr/local/src/e1000e.

2. Untar/unzip archive:

tar zxf e1000e-x.x.x.tar.gz

3. Change to the driver src directory:

cd e1000e-x.x.x/src/

4. Compile the driver module:

# make install

The binary will be installed as:

/lib/modules/<KERNEL VERSION>/kernel/drivers/net/e1000e/e1000e.[k]o

The install locations listed above are the default locations. They
might not be correct for certain Linux distributions.

5. Load the module using either the insmod or modprobe command:

modprobe e1000e

insmod e1000e

Note that for 2.6 kernels the insmod command can be used if the full
path to the driver module is specified. For example:

insmod /lib/modules/<KERNEL VERSION>/kernel/drivers/net/e1000e/e1000e.ko

With 2.6 based kernels also make sure that older e1000e drivers are
removed from the kernel, before loading the new module:

rmmod e1000e; modprobe e1000e

6. Assign an IP address to the interface by entering the following, where
x is the interface number:

ifconfig ethx <IP_address>

7. Verify that the interface works. Enter the following, where <IP_address>
is the IP address for another machine on the same subnet as the
interface that is being tested:

ping <IP_address>

TROUBLESHOOTING: Some systems have trouble supporting MSI and/or MSI-X
interrupts. If you believe your system needs to disable this style of
interrupt, the driver can be built and installed with the command:

# make CFLAGS_EXTRA=-DDISABLE_PCI_MSI install

Normally the driver will generate an interrupt every two seconds, so if
you can see that you're no longer getting interrupts in
cat /proc/interrupts for the ethX e1000e device, then this workaround
may be necessary.