View Full Version : [SOLVED] miro plays sound, but no video

September 4th, 2010, 07:19 AM
After buying my new laptop, i was extremely excited to be able to watch videos on miro with no lag. Unfortunately, it seems like i have a bit of work to do before i get a chance to do so.
I have miro 3.0.3 installed and it seems to be recognizing my videos as audio (when i try to play them, the audio plays, but it stays on my list of downloaded videos). After right clicking on a video, clicking 'edit item', and selecting 'video' as the media type, the only difference is that it shows me a blank screen while playing the audio.
I tried unselecting the option to always play videos in miro (so the video opened in Totem Movie Player), and that too seemed to recognize it as an audio file (it showed me a thumbnail of the video feed and just played audio from that episode).

How can i get my videos to play as videos in miro (not an external player) ?

EDIT: VLC plays the videos fine (so now i know that the issue isn't the videos themselves), but how do i get them to play in miroooooooo
EDIT: All the videos downloaded on Miro are placed in the "audio" playlist in the sidebar.
EDIT: It seems that the problem is with gstreamer... I installed w32codecs. Still nothing ):

THIS WAS SOLVED THANKS TO THIS THREAD (http://ubuntuforums.org/showthread.php?t=1502057)

September 4th, 2010, 07:12 PM

September 8th, 2010, 05:37 AM