PDA

View Full Version : [ubuntu] ATI Xorg downgrade?



Virtual62
September 4th, 2010, 05:32 AM
Hi

I just installed a fresh copy of lucid lynx and Im having issues with the Catalyst Control Center as my ATI graphics card cannot be recognized by it. Apparently the new flgrx drivers are not compatible with my graphics card:

02:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series] [1002:7183]

Although I have seen a post on a related thread, which suggested i should download an older version of the driver, I encountered issues with installing it as my existing version of Xorg is 7.6 and the driver is only compatible for up to 7.4

I would like to know the following:

1. is it possible to remove the existing xorg core with out any risks of ubuntu crashing
2. is it possible to install an older version of xorg? if so how?


if anyone can help me with this issue, it would be much appreciated

sagi456
September 27th, 2010, 10:04 PM
I have the same problem. I also tried using the open source drivers and they partially work, but I still cannot use compiz no matter what I do. And "yes" I have tried disabling kms with radeon modeset=0 but when I do so it doesn't change anything..

Does anyone has a clue on how to fix it??

Mark Phelps
September 28th, 2010, 04:58 AM
I have the same problem. I also tried using the open source drivers and they partially work, but I still cannot use compiz no matter what I do. And "yes" I have tried disabling kms with radeon modeset=0 but when I do so it doesn't change anything..

Does anyone has a clue on how to fix it??

You've hihacked a thread dealing with something totally unrelated to your problem -- which has absolutely nothing to do with downgrading the version of X-server.

If you want responses, you need to start your own thread with a proper title -- and stop hijacking other people's threads.

sagi456
September 30th, 2010, 07:45 PM
You've hihacked a thread dealing with something totally unrelated to your problem -- which has absolutely nothing to do with downgrading the version of X-server.

If you want responses, you need to start your own thread with a proper title -- and stop hijacking other people's threads.


No I don't think I have. I have exactly the same problem as Virtual62. I only added the fact that, since the ATI Linux proprietary driver didn't work for me, I have also tried the Open source drivers - which appearantly are not efficient enough in my case...

I am also interested in a possible XORG downgrade solution...

Temüjin
September 30th, 2010, 09:08 PM
Xorg downgrade worked with jaunty/9.04, but it won't work on newer buntus. Try something else..