PDA

View Full Version : [gnome] How to install Banshee 1.7.5



arrimapirate
September 4th, 2010, 04:58 AM
Banshee 1.7.5 supports the ipod touch and iphone but i can not figure out how to get it on Ubuntu. Its not in synaptic yet and i can not compile from source because it always says

configure: error: Package requirements (gstreamer-0.10 >= 0.10.12
gstreamer-base-0.10 >= 0.10.12
gstreamer-plugins-base-0.10 >= 0.10.12
gstreamer-controller-0.10 >= 0.10.12
gstreamer-dataprotocol-0.10 >= 0.10.12
gstreamer-fft-0.10 >= 0.10.12) were not met:

No package 'gstreamer-0.10' found
No package 'gstreamer-base-0.10' found
No package 'gstreamer-plugins-base-0.10' found
No package 'gstreamer-controller-0.10' found
No package 'gstreamer-dataprotocol-0.10' found
No package 'gstreamer-fft-0.10' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GST_CFLAGS
and GST_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


So is there anyway to install it now?

bowens44
September 4th, 2010, 02:15 PM
you have to install all the missing packages

I have successfully built and installed it but it was very time consuming.

hriqe
September 4th, 2010, 02:25 PM
You can use Banshee Active Development PPA (https://launchpad.net/~banshee-team/+archive/banshee-unstable) or the Banshee Daily Build PPA (https://launchpad.net/~banshee-team/+archive/banshee-daily).
Works just fine.

howefield
September 4th, 2010, 02:28 PM
You can use...

This will give you 1.7.4 at the moment.

arrimapirate
September 5th, 2010, 06:31 AM
you have to install all the missing packages

I have successfully built and installed it but it was very time consuming.

Do you mean compile from source? Ill give that a try.


hriqe][/U]You can use Banshee Active Development PPA (https://launchpad.net/%7Ebanshee-team/+archive/banshee-unstable) or the Banshee Daily Build PPA (https://launchpad.net/%7Ebanshee-team/+archive/banshee-daily).
Works just fine.

I can never get those ppas to work right. It might be because i run 10.10

arrimapirate
September 5th, 2010, 08:33 AM
Okay im working on compiling from source but i keep getting an error about BOO not being installed. I installed the recent version from synaptic but it still said it wasnt installed. Any one else had that problem?

oroberos
January 9th, 2011, 12:56 AM
Install libboo-cil-dev from synaptic.