PDA

View Full Version : [ubuntu] Flash issues..



Baldrick_NZ
September 3rd, 2010, 09:28 AM
Having downloaded 'flash-non-free' from the repo, I find that Totem will only play the sound track, with a black screen.

VLC will play flash files, but only if you don't move the VLC window during playback. If the VLC window is moved, the screen goes black but the sound keeps playing. Curiously, the video playing 'flashes' on and off while the window is being moved.

Ideally, I'd like to be able to use either apps.

Any help resolving this would be much appreciated..

garvinrick4
September 3rd, 2010, 09:47 AM
Just so you make sure you have all the codec's you need and flash use this and let it install what you do not have. The second one is for dvd's.


sudo apt-get install ubuntu-restricted-extras


sudo apt-get install libdvdcss2

Baldrick_NZ
September 3rd, 2010, 10:27 AM
Thanks, but didn't help. Any other ideas?

garvinrick4
September 3rd, 2010, 10:47 AM
Thanks, but didn't help. Any other ideas?
Does youtube.com play its video's?

Baldrick_NZ
September 3rd, 2010, 11:05 AM
Does youtube.com play its video's?

yes, but sometimes with artifacts, usually white outlines on faces, etc...

reiki
September 3rd, 2010, 01:35 PM
If you have Desktop Effects turned on, try turning them off. I love my spinning cube desktop switcher, but for some reason, when I turned off Desktop Effects, my flash started working perfectly. ALL of my flash problems went away.

Not the perfect solution, I'll admit, but I can do without the effects until someone smarter than me figures out why flash is so screwed up in 64-bit 10.04. Or maybe they know why, but are working on the fix.

Baldrick_NZ
September 4th, 2010, 01:03 AM
If you have Desktop Effects turned on, try turning them off. I love my spinning cube desktop switcher, but for some reason, when I turned off Desktop Effects, my flash started working perfectly. ALL of my flash problems went away.

Not the perfect solution, I'll admit, but I can do without the effects until someone smarter than me figures out why flash is so screwed up in 64-bit 10.04. Or maybe they know why, but are working on the fix.

Thanks Reiki, but that's not it. I can't enable desktop effects, SiS video drivers - arrrggg!