View Full Version : [SOLVED] "udev unconfigured" problem causing refusal to boot

September 2nd, 2010, 09:35 AM
I have just attempted to apply the updates to my installed packages and add some others including what I hope are unrelated packages such as:


A reboot was required after which I get the following message:

udevadm trigger is not permitted while udev is unconfigured.

Subsequently, after waiting, the root device is not resolved and I get "dropped" to BusyBox. I can successfully mount the 4 existing partitions from here, but BusyBox doesn't really offer the tools to do much, I believe, so I reboot with the USB pendrive live installation of Xubuntu and mount the partitions and attempt to recover the installation something like this in a terminal:

sudo bash
mkdir -p /mnt/host
mount /dev/sda5 /mnt/host
mount /dev/sda1 /mnt/host/boot
mount /dev/sdb1 /mnt/host/home
mount /dev/sdb2 /mnt/host/usr
chroot /dev/host
dpkg --configure -a
update-initramfs -u

I have also hacked the host's /etc/fstab so it uses /dev/sdxn instead of the UUIDs. All of the partitions function correctly as far as I can tell. None are full and all are writable.

I haven't yet managed to successfully enable GRUB which doesn't offer alternative kernels from which to boot. I am at a loss how to proceed: I just can't figure out how to "configure" udev or at least convince it to mount the partitions. The UUID seems to be being used for that (failed) purpose, judging by the message shown after the mount timeout at boot time.


September 2nd, 2010, 10:20 AM
I had the same problem and solved it.

Try to boot an other kernel, that should still work.
sudo update-initramfs -u -k 2.6.32-24-generic

After a reboot the kernel should find the disks again.

September 2nd, 2010, 11:05 AM
Phew! I was concerned regarding the kernel version being the same as my most recent one (I really have to get to understand the workings of this area better) and that I got 3 grep errors when running the command, but thankfully I'm now back up and running! :-D

Thank you so much! I hoped there would be a simple solution. :-)

Cheers for now,