PDA

View Full Version : [ubuntu] Fresh install: how do I find RAID5?



disconap
August 26th, 2010, 08:57 AM
So the server crash/corruptions I posted about earlier, I finally gave up and reinstalled/configured my server. Everything went fine, it's running great; however, I plugged in my RAID5 sotrage box (via eSata) and I can't find the RAID5. It's not listed anywhere under /dev/, though the individual drives are, and mdadm either can't see it or, for some reason, can't assemble it. There are files I really need off it (which is why it was set up as a RAID5 in the first place, and why it was external). How can I mount the RAID? I searched around/read through mdadm manuals and forums/sites for the past couple hours and didn't find anything that worked...

EDIT TO ADD MORE INFO:
RAID5 built on devices sda2-5 (3 active, one parity) using mdadm

craigp84
August 26th, 2010, 10:43 AM
sudo mdadm -A /dev/md0 /dev/sda2 /dev/sda3 /dev/sda4 /dev/sda5

disconap
September 11th, 2010, 10:54 AM
Sorry for the bump, just realized I never responded. I ended up having to rebuild the raid but it all worked out fine. Thank you for the help! :)