View Full Version : [SOLVED] ATI 4770hd

August 26th, 2010, 04:41 AM
Hello all. 1st I am very green to Ubuntu, so please go easy on me. I seem to be having an issue that when ever I install the driver from my ATI HD4770 Ubuntu will not boot. I will get stuck at the screen that says Ubuntu and it will not go anywhere.

So here are some of the details

I am running 10.4 64bit
AMD Duel Core 5500
Razor Barracuda Sound card
Gigabyte GA-K8n9 Mainboard

After installing Ubuntu, I will update the os with the system update.

I then reboot the OS.

Once rebooted I will go to System>Administration>Hardware drivers.

After a scan I will see that I need the FGLRX Driver.

After this is installed I will reboot the PC.

And this is where it ends. I get to the screen with Ubuntu and the 5 red dots and it freezes. No I did also notice that the screen rez seems to be bigger and off center as I have a wide screen monitor and I can see on the left hand side a nice black strip tike the screen has been pushed right.

Again I am very new to this, so any detailed help and I would be grateful.

Thank you ahead of time.

August 26th, 2010, 04:50 AM
It may be that you are missing a working config file.
After you install the fglrx driver and before you reboot, run the following command at the command prompt:

sudo aticonfig --initial -f

This will create a working xorg.conf file for this new driver.


August 26th, 2010, 05:28 AM
Unfortunately, this did not work. At this point I am having to run from CD as a now I can not get back in to Ubuntu. I have tried to press my esc key so that I can unload the driver but this is not working. Any suggestions?

August 26th, 2010, 11:28 AM
Did it not work because you tried it and it didn't work or because you are unable to type in the command? If the latter...

Try booting from the hard drive again and holding down the shift key during the bootup sequence. When the grub menu appears, select recovery mode. This will start ubuntu in a special mode where it doesn't load the graphical interface. From here, run:

aticonfig --initial -f




August 26th, 2010, 12:40 PM
To remove the driver, boot to recovery mode, drop to prompt (with networking), and follow: http://wiki.cchtml.com/index.php/Ubuntu_Lucid_Installation_Guide#Removing_the_Drive r

^You can also try manually installing Catalyst 10.8 using that guide. Maybe it will work better..

August 26th, 2010, 03:14 PM
Correct TOZ. i did the command But when I rebooted It just caused the same issue.

So to start off on a new foot, and Since I had nothing in the PPC really I just re wiped and reinstalled Ubuntu.

I then went to the link provided by Temüjin (http://ubuntuforums.org/member.php?u=327594) and Manually installed the Catalyst driver after having to build the .deb, The driver is installed and all is well now.

Thank you both.