View Full Version : [ubuntu] 9.04 ok but 10.04 hangs on Toshiba Sat M200

Terry Arnott
August 24th, 2010, 02:09 AM
Hi all, hopefully someone can help here.....

I have already searched but can't find a similar problem posted so sorry if I missed it...
I should also say that I am a Hardware person primarily, and while I have had a little bit of a 'play' with ubuntu in the past, I am still very much a begginer, so please try to keep suggestions to a noob level of instruction. Assume I know nothing and we can't go wrong.....

I have a little Toshiba Satellite M200 which came with VISTA (ugggh!) Needless to say Vista has fallen over its own huge feet and landed in a scrambled pile. I have mnaged to copy off all data I needed, and then tossed up between XP or Ubuntu for the re-install. I decided to go with Ubuntu to try and get used to it on a single machine before (hopefully) changing over the rest of the computers here to eventually be M$ free.

I booted the M200 from a Live-CD of 9.04 which I already had from a while back and it ran fine. Ok, looks good so far.
I then checked for the latest version and downloaded/burned the live-cd of 10.04 which also ran fine on the M200 when I booted it.
I istalled 10.04 from the live-cd but after the initial reboot (and all boot attempts since then) the computer hung while still loading (before it reached the GUI) and had a corrupted screen, lines, coloured blocks etc.....

I wiped 10.04 and installed 9.04 instead just to get it up and running.
The 9.04 install went fine, it rebooted and still worked so I did all the updates it wanted to, then rebooted, everything was still fine.
After the reboot it offered to upgrade to 9.10, so I did that, then rebooted.
It all seemed fine while booting, and made it all the way into the GUI, but now the touchpad no longer worked.
I plugged in a USB mouse and that worked, but I could find no way to get the touchpad working again.
In the end I blew-away 9.10 and again reinstalled 9.04 and did the updates, but stopped before upgrading to 9.10.

This is the state of the M200 at this stage, running stable on 9.04, although the wireless network sems to keep dropping out for some reason and not reconnecting.

I would like to try to get 10.04 up and running as I really like the look of it (love the loading screen), the new communications arrangement for IMs etc, and seriously, whats the point of installing an older version of an OS when you actually prefer the latest one?

Can anyone give me some info on why 10.4 would run fine from the live-cd but fall over when its installed? I was thinking it could be display drivers or something, that only get configured and set up on a full installation, but I have no idea how to work around this.

On a side note, I booted a desktop from the 10.04 disk and it all seems happy except that it wont go above 800x600 screen res, would this be solved with a full installation where it can then set up display drivers properly etc?

I thank you all in advance for any help you can offer....


Terry Arnott
August 24th, 2010, 05:39 AM
OK, I've been doing a little more "playing" and discovered an interesting fact.

10.04 did NOT stop working once it was installed, it stopped working when I plugged in the power!

The 10.04 live-cd will boot and run fine as long as I don't have the power plugged into the laptop, but as soon as I plug it in the screen goes corrupt and the machine hangs.

And another little tid-bit of info....
9.04 (installed or live-cd) can not use the wireless network but 10.04 (live-cd only tested at this stage) can.

Any help is welcome......