View Full Version : [ubuntu] how to get D-Link DWA-525 working on Ubuntu 10.04

August 23rd, 2010, 11:15 PM
Hey guys,

so today i bought myself the DWA-525 wireless PCI desktop card, and had a heck of a time installing it in ubuntu 10.04, until i found this! So i thought i'd share it with others who are in the same situation! I tried to make this a noob friendly as possible


0. Remove the PCI card from the computer (if you plugged it in already)

1. Download the attached file (i didn't make this, and i don't know where i found it, its a result of 4 hours of digging through the net :P)

2.unzip the file

3.open a terminal and find the unzipped folder

4.once in the folder type "make" and hit enter

5.When that's done, type "sudo make install" and hit enter

6.once thats complete, turn off your pc and plug in the card

7. turn on your pc... and DONE! it should be working wonderfully now! or at least it did for me. good luck anyone trying this!

Arte Aplicada
September 8th, 2010, 12:57 PM
Man, I tried EVERYTHING in the last 2 months, and the only thing that worked was THIS. I was as simple as installing the drivers with the card disconected! AMAZING!

Thanks! I love you!


September 20th, 2010, 04:58 AM
I just used the above zipped driver code with 10.10 (beta) & a DWA525 - It worked!!
Thanks - I've been trying for a week to get this thing online
You rock Golesy

September 21st, 2010, 02:46 AM
Thanks Golesy (http://ubuntuforums.org/member.php?u=1135921) this thing works perfectly!

Oh..and a hint, you don't even have to remove the card, i forgot, and was sure i made a mistake...but hey...it works!

September 25th, 2010, 11:27 PM
Yay, it worked (after hours of stuffing around)! I also didn't have to remove the card. Thanks so much.

September 26th, 2010, 11:27 PM
I found where the driver came from: http://ftp.dlink.ru/pub/Wireless/DWA-525/Drivers/Linux/

I was a bit worried about it being an alpha version, but I guess coming directly from a d-link site gives it a bit more credibility, though I couldn't find an actual link to the driver the from the Australian, US or Russian sites.

October 4th, 2010, 01:35 PM
Thanks a lot. This saved me untold time and frustration. It worked without removing the card - just needed a reboot after installing.

Lloyd Welch
October 15th, 2010, 05:52 AM
I was abit scared, but after following the instructions; I was able to get it to work.


November 10th, 2010, 10:33 PM

The driver seems to have installed correctly, but I cannot seem to connect to my wireless router.

What I get from lshw -C network:

description: Wireless interface
product: RaLink
vendor: RaLink
physical id: c
bus info: pci@0000:02:0c.0
logical name: wlan0
version: 00
serial: f0:7d:68:5f:4c:2b
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rt2800pci driverversion=2.6.35-22-generic-pae firmware=N/A latency=64 maxlatency=4 mingnt=2 multicast=yes wireless=IEEE 802.11bgn

And this is what I get from iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

I have also configured the SSID, MAC Address and password (WPA Personal) of my router in the Network Connections.

Could it be that my wireless adapter does not work properly?
Any help is much appreciated :)

November 11th, 2010, 07:32 PM

After following the steps in these threads:


I managed to get the wireless adapter to work.

Basically the only thing I was missing was to blacklist rt2800pci driver in the /etc/modprobe.d/blacklist.conf file

Also in the 2nd link I mention above you can find newer drivers to the ones posted a few posts above (http://art.ubuntuforums.org/showpost.php?p=9893068&postcount=6)

Thanks :)

December 12th, 2010, 10:23 PM
Work just fine thank you very much!! Awesome!

December 29th, 2010, 11:50 PM
You won't believe this, but I used the attachment & followed the steps from Golesy (http://ubuntuforums.org/member.php?u=1135921)'s first post, and though spending lots of money on an international cell call, I manage to guide a guy that don't even know where the keys are on the keyboard and we hardly agreed on what is the pronunciation of each character from each word! After all steps were followed, I used teamviewer to get control on his desktop through lots of firewalls and NATs, and fixed the sound in Ubuntu as well.

All due to exactly detailed & simple steps wrote by Golesy (http://ubuntuforums.org/member.php?u=1135921) !!!
Dude, I would hire you to write documentation and tutorials!

January 20th, 2011, 11:42 AM

February 3rd, 2011, 09:07 AM
Great job. Works like a charm.

February 15th, 2011, 02:05 PM
Hey there buddy,

Thanks a lot for this! You rock dude! Works awesome!

Lorenzon Diego
March 18th, 2011, 09:56 PM
Thank you for the info.
It worked fine for me.
Now the WIFI connection is working, but the sound disappear.
Sombodi know how to resume the sond?
Thanks in advance:)

March 23rd, 2011, 01:45 AM
Just try it, on a Dell GX150, not problem with 10.04

I began with 10.10 and no card activation. Tryed different installation as descrive as above form different threats, with no success.
new user of linux and Ubuntu

April 5th, 2011, 03:21 AM
Awesome! I just had to deactivate the rt2800pci driver as eldudorinio did, and everything works just fine!! Thank a lot!!

April 21st, 2011, 01:10 PM
thank you!!

May 5th, 2011, 07:13 PM
Only after following this advice (http://ubuntuforums.org/showpost.php?p=10055176&postcount=4), namely editing black list, was I able to make my DWA-525 work. Without blacklist driver installation hasn't worked in Kubuntu 11.04.
Thank you for this topic, it makes so many people happy!:popcorn:

May 26th, 2011, 03:48 PM
Confirming this works for 11.04 after blacklisting the ralink drivers like so

follow instructions for installing the driver that golesy (legend :guitar: ) gave but before rebooting do the following....

gksudo gedit /etc/modprobe.d/blacklistconfthen add

blacklist rt2800pci
blacklist rt2x00pci

save then exit (after you exit it may give some errors about file not found, just ignore them it still works) then shut down, put the card back in and start her up. It should all work fine then and also fixes problem some have had with natty hanging when trying to shutdown or reboot.

EDIT: just found out that after any kernel update you will need to repeat step 5 on golesy's list. That is go into the folder where the driver is and type

sudo make install

then reboot

May 27th, 2011, 10:11 PM
Thank you soo much. Spend a hour or so trying just the blacklist thing, and even different wireless cards. Finally got it working

July 17th, 2011, 05:34 PM
I am really new, less than an hour on Linux. I downloaded the file cited above, extracted it, moved to that directory and typed "make" as instructed. Error: no makefile. So, I looked at the files and noticed that the makefile was actually "Makefile", so typed "make Makefile". Error: no rule. OK, I am stumped. All of the messages indicate that this process was facile. The only difference I can see is that I am using a later version (downloaded a day or so ago from the Ubuntu site). Please help and remember: I have never used Linux before.

July 17th, 2011, 06:26 PM
Whoops! When I looked for my post, I realized there were more than three pages. I followed the blacklist advice and also discovered I was in the wrong directory. I am now using my wireless card. Thanks to the posters above. Sorry for the noise.

October 9th, 2011, 05:45 PM
This is still working in October 2011! :guitar:

November 18th, 2011, 01:07 PM
I have a big problem about installation of wireless driver in backtrak5:(
(I have a linux backtrack 5.)
I have downloaded dwa525 driver but when i write "make" , it shows me this error:


root@bt:~/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2# make
make -C tools
make[1]: Entering directory `/root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/tools'
cp -f os/linux/Makefile.6 /root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/Makefile
make -C /lib/modules/ SUBDIRS=/root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux modules
make: *** /lib/modules/ No such file or directory. Stop.
make: *** [LINUX] Error 2


then , I created that folder by myself ( the folder name is "build")
and when I tried it again , it shows me this error in this time:

root@bt:~/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2# make
make -C tools
make[1]: Entering directory `/root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/tools'
cp -f os/linux/Makefile.6 /root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/Makefile
make -C /lib/modules/ SUBDIRS=/root/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux modules
make[1]: Entering directory `/lib/modules/'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/lib/modules/'
make: *** [LINUX] Error 2

could you please help me how should I solve it?

with best regards.

November 18th, 2011, 05:29 PM
any body there??????????:confused:

November 20th, 2011, 09:16 AM
?????????????????????????????????????????????????? :o

January 6th, 2012, 11:05 AM
Thanks bro!
this worked, without any restarting.

But the notification area stopped showing my network icon, and no amount of coaxing cud bring it back.
finally, got the right way of solving that in this post (http://askubuntu.com/questions/4360/no-network-manager-icon-in-the-notification-area-so-i-cant-use-my-vpn-connecti)
hope it helps those rare guys who, in future, face my problem

January 9th, 2012, 11:46 PM
for me this did not work but i'm using 11.04 but i solved it this way

1. Install the card and power up the machine.

2. Open the terminal and run


In the list you will see:

Network Controller: Ralink Device 3060 0

So now we know what device we need drivers for.

3. Go to http://www.ralinktech.com/support.php?s=2 and download the RT3062PCI/mPCI/CB/PCIe(RT3060/RT3062/RT3562/RT3592) drivers.

You’ll be prompted for your name and email but you don’t need to sign into anything.

4. Extract the package and cd to the directory.

5. We need to make a slight modification to the configuration for the driver:

nano os/linux/config.mk

And set:

# Support Wpa_Supplicant

# Support Native WpaSupplicant for Network Manager

By default they are both set to ‘n’. Save and close the file.

6. From the top level directory, compile and install the driver:

sudo su
make && make install

You need to use ‘sudo su’ and not just ‘sudo’ so it creates the directories properly.

7. After compilation, and whist still root, modprobe the driver:

modprobe rt3562sta

You should get no output signalling success.

8. Now an important step. We need to blacklist a conflicting driver that will be loaded preferentially for this network card.

sudo nano /etc/modprobe.d/blacklist.conf

and enter the following line at the bottom of the file:

blacklist rt2800pci

Save and close.

9. Restart the machine.

10. When the machine is back up, verify the driver has been loaded and is being used by the device:


You should see the following in the list:

rt3562sta 924607 1

11. Now, launch the Network Manager and it should have detected the available wireless networks and you can configure the one you want.

March 8th, 2012, 01:20 AM
edit: stupid question, i forgot to install gcc...

September 18th, 2012, 12:25 AM
Thank you man, It works to the perfection :)

February 17th, 2013, 06:42 AM
Hello guys.
First of all thanks for making this forum such a nice way for learning to use ubuntu and linux.

I'm trying to make my wireless board works but i cant. In my last try i got these erros:

root@dktp:/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2# make
make -C tools
make[1]: Entering directory `/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/tools'
cp -f os/linux/Makefile.6 /home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/Makefile
make -C /lib/modules/3.5.0-17-generic/build SUBDIRS=/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux modules
make[1]: Entering directory `/usr/src/linux-headers-3.5.0-17-generic'
CC [M] /home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/../../os/linux/rt_linux.o
/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/../../os/linux/rt_linux.c:1646:10: error: unknown field ‘ndo_set_multicast_list’ specified in initializer
make[2]: *** [/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/../../os/linux/rt_linux.o] Error 1
make[1]: *** [_module_/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-17-generic'
make: *** [LINUX] Error 2
root@dktp:/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2# ^C

root@dktp:/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2# make install
make -C /home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux -f Makefile.6 install
mkdir: cannot create directory `/etc/Wireless': File exists
make[1]: Entering directory `/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux'
rm -rf /etc/Wireless/RT3060STA
#mkdir /etc/Wireless/RT3060STA
mkdir -p /etc/Wireless/RT3060STA
cp /home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/RT3060STA.dat /etc/Wireless/RT3060STA/.
install -d /lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/
install -m 644 -c rt3562sta.ko /lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/
install: cannot stat `rt3562sta.ko': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/gabriel/Desktop/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux'
make: *** [install] Error 2

I'm noob on linux and i don't know exactly what that means. Can anyone help me to find out how to fix that?

Thanks very much!

March 14th, 2013, 11:25 PM

Does this works with ubuntu server 12.04 ?

I have the DWA-525 5360.

When I do the command :


I get this error :

make[1]: Entering directory `/usr/src/linux-headers-3.5.0-23-generic'
CC [M] /home/laprise/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/../../os/linux/rt_linux.o
/home/laprise/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/../../os/linux/rt_linux.c:1646:10: error: unknown field ândo_set_multicast_listâ specified in initializer
make[2]: *** [/home/laprise/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux/../../os/linux/rt_linux.o] Error 1
make[1]: *** [_module_/home/laprise/2010_01_28_RT2860_Linux_STA_v2.3.0.0_Alpha_v2/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-23-generic'
make: *** [LINUX] Error 2

Please help, it's my second week trying to find the problem.

Thank you ! :)

April 11th, 2013, 04:31 PM
For the 5360 model I solved it with http://ubuntuforums.org/showthread.php?t=2008849&p=12302336#post12302336

Good luck!