PDA

View Full Version : Brother MFC 7220 Printer - Driver Fail



ve2
August 23rd, 2010, 02:22 AM
Anybody else using this printer? I have tried the driver direct from Brother, requires cups and the driver. Both installed, both fail. I read on another forum to try a Brother HCL type and it works, but why?

gordintoronto
August 23rd, 2010, 05:23 AM
"Fail" is too open-ended. "I did X and Y and expected Z, but instead this other thing happened."

ve2
August 23rd, 2010, 11:11 AM
I 1st went to http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html and downloaded CUPS & LPR. All seemed to if installed fine. Started my printer.. I think it found the driver.. all seemed to be good. Then attempted a print test.. and the printer attempted to print endlessly, but no print.

Found on another forum: http://forums.linux-foundation.org/read.php?24,338

Last post on that page... Suggested to install the HL-2060.

That worked 100% why?

gordintoronto
August 24th, 2010, 01:59 AM
One assumes the printer part of an MFC 7220 is a 2060, and the 7220 driver has a bug. "Attempted to print endlessly"? As in, a light flashed?

Is it a laser or dot matrix? My Brother laser has been flawless since I bought it.

rthonly2001
February 8th, 2013, 03:52 AM
I realized that this reply goes to an old post dated on 2010, but since this was the only link I found to solve the problem of adding a new linux driver for the brother MFC-7220. I thought that it would still be important to bring the answer to the issue. So here is the link to my site where I posted the instruction.
Link : How to add Brother MFC-7220 driver to Cups in ubuntu 12.4 (http://rth.3anillos.org/index.php?action=artikel&cat=13&id=77&artlang=en)

wildmanne39
February 8th, 2013, 04:46 AM
Thanks for sharing and please do not post in threads that have not had activity for a year or longer, since this is an old thread it has been closed.