View Full Version : [ubuntu] 10.04 freeze

August 19th, 2010, 03:15 PM
Hi, I've been running 10.04 on an AMD64 box since its release. Prior to that I've run 9, 8, 7 releases of Ubuntu on the same box.

The box has 4 SATA disks in it. 3 of them are configured for software RAID5, and the other holds the OS. Typically when there's a new major Ubuntu release, I'll wipe the OS, and re-install the latest, and remount the RAID. Everything had been working fine...until yesterday, after I ran the autoupdater.

Upon a reboot, it failed to mount /dev/md0 through /etc/fstab. mdadm indicated that the superblocks were bad. I tried doing some investigation with mdadm, but I can only get so far before it just freezes. When it freezes, the screen paints garbled lines, and the system is unresponsive. I can't get in via ssh either.

I tried booting to the cmd line, and running fsck...it also hangs after a while. I booted back into Gnome, and ran fsck on /dev/md0 -- it ran for about 10 minutes, and then froze.

I tried inserting the CD to re-install the OS -- just to try to get a stable OS. My thinking was that if I can get the OS back to a stable known state, without the /dev/md0, then I can work on fixing the raid, but in the installer screens, after I pick the keyboard layout, it froze again -- screen painted garbled, and it was unresponsive.

There is no information in /var/log/messages other than the standard boot info -- no kernel panic, no errors reported.

I'm working with both hands tied behind my back b/c I don't know what is causing it to hang, and I can't do a lot with the system before it hangs again and I have to do a hard-reset.

I'm hoping someone on the forums can give me some tips on what to try?

August 19th, 2010, 04:13 PM
Very obvious hardware failure. Start with the CPU, be sure the fans are running and that the heatsink is cool enough to touch for about 5-7 seconds and that there is enough airflow (clean fins).
Then the chipset heatsink, then the video.

August 22nd, 2010, 03:45 PM
Yea, I was afraid of that. Turned out to be some faulty capacitors on the mobo. Time for a HW upgrade anyway.

Asus mobo -> Gigabyte mobo
AMD 64 dual core -> AMD 64 quad core
all new memory.

I figured I'd have to just re-install the OS, and remount my raid afterward. Lo and behold the system booted without a hiccup with completely new hardware. It detected that the nvidia chipset no longer existed and asked if I wanted to reconfigure graphics - which I did, and it worked. 2 seconds later I was viewing the desktop, and /dev/md0 was mounted and working just fine.

I was pretty geeked -- I didn't expect that. Kudos to all the fine people that make this OS such a pleasure to work with.

August 22nd, 2010, 09:01 PM
wow, I didn't expect the mobo to fail but glad all worked out.