PDA

View Full Version : [ubuntu] 10.04 server freezes during boot



disconap
August 19th, 2010, 02:45 AM
Hi all--I'm running 10.04 server edition on an Atom 330 chipset using a patriot ps-100 32gb drive. The (minimal + ssh) install went fine, tried rebooting and shutting down/starting up several times, no problems. Set about installing netatalk (had to compile for encrypted passwords), mdadm, ebox, vsftpd and a few other packages I needed, built my external RAID and starting copying over files, everything was working fine. Set the settings as needed to have the network appear on my main machines (mostly macs) and everything was perfect.

Then we had a short power surge/out in the building and the UPS didn't do its job; now I can't get the server to boot back up, I keep getting the following on boot, where it just hangs:

fsck from util-linux-ng 2.17.2
fsck from util-linux-ng 2.17.2
/dev/mapper/ServerMonkey-root: clean, 77803/1855952 files, 519352/7420928 blocks
/dev/sda1 was not cleanly mounted, check forced
/dev/sda1: 210/124496 files (4.3% non-contiguous), 51756/248832 blocks
mountall: fsck /boot [3811 terminated with status 1
init: ureadahead-other main process (732) terminated with status 4

I've searched around for a while but thus far have only found solutions for the regular edition; as I don't have a gui (and currently can't even get into the system) I can't seem to apply any of them. Thoughts? Or even just an explanation of what the above means? I get that there is a problem during fsck so there is a problem with either the install, drive, or both, but I don't have any idea how to go about fixing it (is there, for example, a USB utilities image I can download and boot from to run a fix, something like that)...

brettg
August 19th, 2010, 03:24 AM
You could try booting into recovery mode and running fsck manually on the hard disk. If you can't boot into recovery mode then try a live CD

disconap
August 19th, 2010, 03:32 AM
Sorry, should have mentioned that I've already tried booting into recovery mode and I get the same error. I'm redownloading the disc image to try to repair (hopefully not to have to reinstall, it took about 6 hours to get the install where I wanted it), will post back if that doesn't work. :)

disconap
August 19th, 2010, 03:06 PM
Hrm, I got the Ubuntu Server disc to boot (finally, it's a headless/cd-driveless system, I had to physically take it apart to plug in an old IDE drive, since the USB method simply doesn't work), but recovery is trying to reinstall the OS entirely; is this normal?

kgatan
August 19th, 2010, 05:27 PM
I had a similar problem earlier with fsck, i dont remeber exactly and i might be totally wrong :)

I adjusted the fsck value in fstab for my fsck problem on the specific disk.


In fstab you have somthing like

/dev/sda1 /<mount point> ext4 errors=remount-ro 0 1


Set the last "1" to "0" instead and try booting again.



But beware, im noob and take no responsibility for my suggestions :)