View Full Version : [ubuntu] Tracker Search Tool Won't Install Correctly

August 17th, 2010, 07:39 PM
Hello Everyone, I'm installing the tracker search tool 0.8.15 for gnome on ubuntu 10.4. I've used synaptic to install it & it launches from the accessories menu but there are no menu options to configure it. There is nothing in the categories list, no method to specify a file type to search for, or a directory to search in. The only menu available is when I right click in the text area which contains nothing to specify search file types, directories, etc. The only thing that can be used is the search box, which does accept text but gives no results to searches, regardless of the words that I type which I know exists in text files. So at this point the program doesn’t seem to be installed correctly. I've removed & reinstalled it multiple times. I've also installed it along with the tracker-utils packages & it still does the same thing. Then I removed it & used apt to install the package tracker-search-tool, which gives the same results. Then I removed it using sudo apt-get autoremove tracker-utils , sudo apt-get autoremove tracker-search-tool , & sudo apt-get autoremove tracker, all of which went OK. I then reinstalled it through synaptic & it still doesn’t function. Then after autoremoving it again, I installed both tracker-utils & tracker-search-tool s using apt. It still does the same thing. I then used the sudo apt-get remove --purge tracker-search-tool, which generated an Invalid operation tracker-search-tool response. It did the same thing when I tried to remove the package name tracker-utils. However, this seems to be the name of the package according to synaptic as well as apt-cache show tracker, which lists both tracker-utils & tracker-search-tool. Also, I was able to reinstall it with apt using the exact same package name (tracker-search-tool) which the purge command said was invalid. In synaptic I notice that the following packages pertaining to it are installed: tracker-utils, tracker-gui, libtracker-miner-0.8-0, tracker-extract, & libtracker-client, tracker-search-tool, & tracker-miner-fs. According to the site https://help.ubuntu.com/community/MetaTracker, it should be able to be installed using only the tracker-search-tool package, although it is for an older version of Ubuntu. But even still, the program appears in synaptic, which, so far has automatically included the necessary files for all other programs that I’ve installed. Also, as far as documentation on how to actually use it, it seems there’s not much available. The site http://projects.gnome.org/tracker/documentation.html says to go to this site, http://live.gnome.org/Tracker/Documentation. But there is no introductory manual on its usage for the gui, only some command line methods of searching. Nothing about configuring it through menu options or how to find them, or how to specify what file types to search for, etc. There is a man page available which doesn’t have much information other than a pointer to –help-gnome. I then use this command: tracker-search-tool –help-gnome , & receive the following vague response: Usage: tracker-search-tool [OPTION...] tracker-search-tool GNOME Library --disable-sound Disable sound server usage --enable-sound Enable sound server usage --espeaker=HOSTNAME:PORT Host:port on which the sound server to use is running --version I searched this forum for this issue using keywords such as “tracker search tool no menu,” & “tracker search tool,” which gave no results. The phrase “no menu tracker search tool”gave some results but nothing pertaining to this. So, it seems that I’d like to make sure this is installed correctly, then find some information on how to actually use it. My guess is that once its installed correctly there should be some basic information on its usage available. Any suggestions would be appreciated. Thank You, Mark