View Full Version : [SOLVED] Problem with ubuntu software center

August 17th, 2010, 11:44 AM

I am having the following problem with the ubuntu software center.
When I try to install or remove a new application (all of them), the following errors appears:

The installation or removal of a software package failed.
E:I wasn't able to locate a file for the kbluetooth package. This might mean you need to manually fix this package. (due to missing arch): I am new to linux and I have no idea where the problem come from or how to fix it.

Can you please give me some tips, maybe some diagnostic I should do?

Thanks in advance

August 17th, 2010, 01:39 PM
If you boot the machine and then run

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

do you get any error messages?

If that is working: Can you install the same package through Synaptic?

August 17th, 2010, 02:00 PM

I think I solved it,

I just upgraded the broken package from the synaptics, now everything seem to work fine.

Thanks again!