View Full Version : [ubuntu] Reboot = Fatal Stop Error - Kernel Panic

August 17th, 2010, 06:24 AM
My most recent updates to Ubuntu 10.04 {stable} were around 7pm EST 8-16-10 ~100mb of files - ubuntu ftp server ftp.ussg.iu.edu, i think.
When I rebooted prior to the updates, all went well, then the immediate following boot created this error:

BEGIN ERROR--------------------------

Target filesystem doesn't have /sbin/init.a - 99d0ae2fd8e95c4
run - init: /etc/init: Permission Denied

[1.632956] Kernel Panic - not syncing Attempted to Kill init!

END ERROR-----------------------------

I don't want to be a long-winded weirdo so I won't detail ALL of my pc specs immediately in case some admin already knows of this error.

I say this because my pc is along the lines of much eSATA, 2 usb hubs, and 9 HDD's of 7000 GB - so it's complicated but I didn't meddle with anything physical to get this error...

Thanks for any help btw, it will be ridiculously appreciated :)

August 17th, 2010, 08:06 PM
I had the same problem and managed to solve it. Check here (http://ubuntuforums.org/showthread.php?t=1555031).
Just be sure to make the appropriate changes according to your problem, i.e., replacing my /sbin/init file with your /sbin/init.a and my /dev/sda1 with whatever is appropriate for your system.
Hope this works!

August 18th, 2010, 04:07 AM
although I seriously appreciate the effort/advice, my PC is still being a cruel oaf and after I tried your method just like you said ... I got the same error again.

... ughhh ... any other suggestions?

August 18th, 2010, 03:36 PM
Nope, sorry. As far as i can guess, it is a Permissions issue, so i thought changing back the permissions would solve it. If it doesn't, then I have no clue what else to do. Worst case, you'll have to re-install, but don't hurry to do that; look and ask around first.

August 19th, 2010, 05:03 AM
k thanks, much appreciate the help - i guess i'll have to investigate and hunt down more options :?

August 22nd, 2010, 01:41 AM
... so ... no other ideas ??? [unfortunately when left to my own devices, I am now stuck] --> I'm just curious b/c I found it helpful that somebody else had this error, and if the error is between two individuals of completely separate PC setup/location, I would think that it's not just some random crap that I did personally. I tried every logical combo/attempt at the suggested permissions settings, and they were all to no avail, and at that - the error message has neither progressed nor been modified. I thought perhaps this would be similar to a bug of sorts but on a ridiculously smaller scale, I just cant figure out whether it's strictly an OS issue I have encountered or if there is a technical physicality to the matter ???

August 25th, 2010, 03:28 AM
I checked the other thread that NightShade referenced and based on that and myself there seem to be at least two of us with ongoing unsolved issues. That thread seems to have been closed with some of us still in the dark about the matter

August 31st, 2010, 02:19 AM
Out of curiosity:

Is there a way people, such as myself, can pay Canonical directly for support issues. If so, what route would I go to do that?