PDA

View Full Version : [ubuntu] How do i remove the start up logo?



the_jlx
August 15th, 2010, 09:02 AM
How do i remove the start up logo so i actually see what is going on?

Oh another thing how do i Change the autofsck thing as it is stuck on doing a check every reboot wont change from program.

And before someone says edit menu.lst
by using sudo gedit /boot/grub/menu.lst
i can already tell you it is empty
I have no idea where the Grub thats is in use is even installed in my 3 hardisks

candtalan
August 15th, 2010, 09:12 AM
How do i remove the start up logo so i actually see what is going on?

One way for temporary visibility is to press e key when the grub menu appears, then edit the boot string to remove quiet and or splash.

hth

candtalan
August 15th, 2010, 09:14 AM
another possibility is to install the app startup-manager and uncheck the splash box

Fludizz
August 15th, 2010, 09:17 AM
have you tried the following command to find you menu.lst?

find / | grep menu.lst

There might also be configuration in /etc/default/grub, in this file look for GRUB_CMDLINE_LINUX_DEFAULT and remove "quiet splash" from the options. Then update your grub :)

regarding the filecheck... if it runs it every day, it might be that the filesystems are not cleanly unmounted on shutdown?

mcduck
August 15th, 2010, 09:23 AM
How do i remove the start up logo so i actually see what is going on?

Oh another thing how do i Change the autofsck thing as it is stuck on doing a check every reboot wont change from program.

And before someone says edit menu.lst
by using sudo gedit /boot/grub/menu.lst
i can already tell you it is empty
I have no idea where the Grub thats is in use is even installed in my 3 hardisks

That would be because Ubuntu 10.04 (and later) use Grub2, which doesn't have a menu.lst file... ;)

Anyway, the file you are looking for is /etc/default/grub, just edit the "GRUB_CMDLINE_LINUX_DEFAULT"-line and remove "splash" from it, save the file and run "sudo update-grub".

(you can also remove the "quiet" if you want, that would give very verbose output during the boot...)

Also note that Plymouth has a text-based theme as well, so if it's otherwise working fine for you and you just want to get more info during the boot then using that might be the way to go.

the_jlx
August 15th, 2010, 09:25 AM
Mkays gonna test the startupmanager now as for the check it is the program autofsck that does it somehow its setting is stored permanently after i once choose arrange checks now

the_jlx
August 15th, 2010, 09:29 AM
I higly doubt i am even using Ubuntus Grub anymore.
Sigh i guess i need to hunt it down lol
startupmanager did not work

Edit:
Mkays edited all GRUB_CMDLINE_LINUX_DEFAULT to just "" lets see what a update grub and sudo reboot does lol

the_jlx
August 15th, 2010, 09:36 AM
Ok only change is i got a pretty blinking line for about 5 seconds...
:(:(
HA found it its dreamlinux grub still being around.
Fixed now just the autofsck thing

the_jlx
August 15th, 2010, 10:08 AM
that would be because ubuntu 10.04 (and later) use grub2, which doesn't have a menu.lst file... ;)

anyway, the file you are looking for is /etc/default/grub, just edit the "grub_cmdline_linux_default"-line and remove "splash" from it, save the file and run "sudo update-grub".

(you can also remove the "quiet" if you want, that would give very verbose output during the boot...)

also note that plymouth has a text-based theme as well, so if it's otherwise working fine for you and you just want to get more info during the boot then using that might be the way to go.

solved