PDA

View Full Version : [ubuntu] show boot test messages on the screen during startup



cccc
August 14th, 2010, 12:38 PM
hi

Howto configure Ubuntu 10.04 to show boot text messages on the screen during startup?

Bucic
November 16th, 2011, 03:52 PM
Bump.

Right now I see only blank screen during startup/shutdown. Startup Manager could configure that but some say it should not be used for newer Ubuntu versions. I removed "quiet splash" from /etc/default/grub.

drs305
November 16th, 2011, 03:58 PM
Removing 'quiet splash' normally allows the messages to be displayed during boot. Did you run 'update-grub' after you saved the change to /etc/default/grub?

If so, do you happen to have multiple installations? If so, at the Grub menu press 'e' to make sure "quiet splash" isn't still displayed on the 'linux' line.

Bucic
November 16th, 2011, 04:03 PM
* 'update-grub' used
* single install
* "quiet splash" isn't still displayed on the 'linux' line

drs305
November 16th, 2011, 04:19 PM
Is the setting for 'gfxmode' set to auto or something odd?

grep "set gfxmode" /boot/grub/grub.cfg

You might try setting it to 640x480 just to see if it's a resolution problem. I'd just edit the /boot/grub/grub.cfg file and check the next time you boot. Don't run "update-grub" or you will erase the change.

I'm assuming you are using the 10.04 version of Grub (1.98), which you can check with "grub-install -v" ).

Bucic
November 16th, 2011, 05:13 PM
Is the setting for 'gfxmode' set to auto or something odd?

grep "set gfxmode" /boot/grub/grub.cfg

You might try setting it to 640x480 just to see if it's a resolution problem. I'd just edit the /boot/grub/grub.cfg file and check the next time you boot. Don't run "update-grub" or you will erase the change.

I'm assuming you are using the 10.04 version of Grub (1.98), which you can check with "grub-install -v" ).
- auto mode
- grub-install (GRUB) 1.99-12ubuntu5

drs305
November 16th, 2011, 05:29 PM
The 'auto' mode in Grub 1.99 is sometimes a bit problematic. Try changing the value to 640x480 or another supported resolution in grub.cfg.

If it works, you can make it permanent if desired by uncommenting GRUB_GFXMODE in /etc/default/grub and running 'update-grub'.

Bucic
November 16th, 2011, 08:27 PM
Currently I'm struggling with LiveCD faster than full install! (http://ubuntuforums.org/showthread.php?t=1873564) so I'll report back sometime later next week. Thank you for your help!