PDA

View Full Version : [SOLVED] IDT audio, no sound @ ubuntu 10.04 64bit



nate_nightroad
August 10th, 2010, 06:49 PM
hi guys,i'm using ubuntu 10.04 64bit and i have a netbook(model is hp mini 110-3004TU) with an integrated HD audio from IDT...

the problem is that no sound is coming out from the speaker, please help

nate_nightroad
August 10th, 2010, 07:00 PM
apparently people from this link has found a solution:

http://ubuntuforums.org/showthread.php?t=1073090

however, it was for xubuntu....i tried to followed but the installation failed

lidex
August 11th, 2010, 09:34 AM
Need some info. Can you post the output of these terminal commands for me please:

uname -a
aplay -l
dpkg -l | grep "alsa"
head -n 1 /proc/asound/card*/codec#*
Terminal="Applications->Accessories->Terminal"
Please also include the make/model of your PC/Laptop.
Please post text output using code tags (the # in toolbar)

nate_nightroad
August 11th, 2010, 11:09 AM
Need some info. Can you post the output of these terminal commands for me please:

uname -a
aplay -l
dpkg -l | grep "alsa"
head -n 1 /proc/asound/card*/codec#*
Terminal="Applications->Accessories->Terminal"
Please also include the make/model of your PC/Laptop.
Please post text output using code tags (the # in toolbar)


vincent@Raiden:~$ uname -a
Linux Raiden 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 05:14:15 UTC 2010 x86_64 GNU/Linux
vincent@Raiden:~$ aplay -l
aplay: device_list:223: no soundcards found...
vincent@Raiden:~$ dpkg -l | grep "alsa"
ii alsa-base 1.0.22.1+dfsg-0ubuntu3 ALSA driver configuration files
ii alsa-oss 1.0.17-3 ALSA wrapper for OSS applications
ii alsa-utils 1.0.22-0ubuntu5 ALSA utilities
ii bluez-alsa 4.60-0ubuntu8 Bluetooth audio support
ii gstreamer0.10-alsa 0.10.28-1 GStreamer plugin for ALSA
vincent@Raiden:~$ head -n 1 /proc/asound/card*/codec#*
head: cannot open `/proc/asound/card*/codec#*' for reading: No such file or directory

my netbook make and model is as follow

HP Mini 110-3004TU

lidex
August 11th, 2010, 11:41 PM
Try re-installing alsa first.
Using a Terminal="Applications->Accessories->Terminal"

sudo apt-get update
sudo apt-get upgrade

sudo apt-get purge linux-sound-base alsa-base alsa-utils


sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop

*gdm and ubuntu-desktop usually get taken out in the process, so we add them back*
Reboot.

nate_nightroad
August 12th, 2010, 07:01 AM
Try re-installing alsa first.
Using a Terminal="Applications->Accessories->Terminal"

sudo apt-get update
sudo apt-get upgrade

sudo apt-get purge linux-sound-base alsa-base alsa-utils


sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop

*gdm and ubuntu-desktop usually get taken out in the process, so we add them back*
Reboot.

done and reboot...still no sound :cry:

nate_nightroad
August 12th, 2010, 10:38 AM
vincent@Raiden:~$ uname -a
Linux Raiden 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 05:14:15 UTC 2010 x86_64 GNU/Linux
vincent@Raiden:~$ aplay -l
aplay: device_list:223: no soundcards found...
vincent@Raiden:~$ dpkg -l | grep "alsa"
ii alsa-base 1.0.22.1+dfsg-0ubuntu3 ALSA driver configuration files
ii alsa-oss 1.0.17-3 ALSA wrapper for OSS applications
ii alsa-utils 1.0.22-0ubuntu5 ALSA utilities
ii bluez-alsa 4.60-0ubuntu8 Bluetooth audio support
ii gstreamer0.10-alsa 0.10.28-1 GStreamer plugin for ALSA
vincent@Raiden:~$ head -n 1 /proc/asound/card*/codec#*
head: cannot open `/proc/asound/card*/codec#*' for reading: No such file or directory

lidex
August 13th, 2010, 06:29 AM
Post these outputs please:

sudo fuser -v /dev/dsp* /dev/snd/* /dev/seq*

dmesg | grep -C1 -E 'ALSA|HDA|HDMI|sound|hda.codec|hda.intel'

nate_nightroad
August 13th, 2010, 10:38 AM
Post these outputs please:

sudo fuser -v /dev/dsp* /dev/snd/* /dev/seq*

dmesg | grep -C1 -E 'ALSA|HDA|HDMI|sound|hda.codec|hda.intel'


vincent@Raiden:~$ sudo fuser -v /dev/dsp* /dev/snd/* /dev/seq*
[sudo] password for vincent:
Specified filename /dev/dsp* does not exist.
Specified filename /dev/snd/* does not exist.
Specified filename /dev/seq* does not exist.
vincent@Raiden:~$ dmesg | grep -C1 -E 'ALSA|HDA|HDMI|sound|hda.codec|hda.intel'

after inputting this code :


dmesg | grep -C1 -E 'ALSA|HDA|HDMI|sound|hda.codec|hda.intel'

nothing came out

lidex
August 14th, 2010, 03:28 AM
Boot into a lower numbered kernel and re-install your latest kernel and kernel-header packages and reboot.

nate_nightroad
August 26th, 2010, 01:21 PM
Boot into a lower numbered kernel and re-install your latest kernel and kernel-header packages and reboot.

done,now the alsa drivers are installed....


vincent@Raiden:~$ uname -a
Linux Raiden 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:38:40 UTC 2010 x86_64 GNU/Linux
vincent@Raiden:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
Subdevices: 0/1
Subdevice #0: subdevice #0
vincent@Raiden:~$ dpkg -l | grep "alsa"
ii alsa-base 1.0.22.1+dfsg-0ubuntu3 ALSA driver configuration files
ii alsa-oss 1.0.17-3 ALSA wrapper for OSS applications
ii alsa-utils 1.0.22-0ubuntu5 ALSA utilities
ii bluez-alsa 4.60-0ubuntu8 Bluetooth audio support
ii gstreamer0.10-alsa 0.10.28-1 GStreamer plugin for ALSA
vincent@Raiden:~$ head -n 1 /proc/asound/card*/codec#*
Codec: IDT ID 7667


please continue to guide me :)

lidex
August 27th, 2010, 06:48 AM
I need you to do this, it will help to troubleshoot. Try running this command in a terminal for 10.04 or later:

ubuntu-bug audio
Reference the Ubuntu-Bug Audio link in my sig.

mike4ubuntu
September 2nd, 2010, 10:49 PM
Keep in mind that the last few Ubuntu versions have PulseAudio integrated with it. It's the preferred sound server. Using ALSA may not work as well anymore. If you go to sound preferences (should be a little speaker icon on your main gnome panel) check to see if you can hear any sound effects when you click on them on the effects tab. If not, you may have to set the output device on the output tab. If you have a driver problem with that hardware, you may have to get another sound card. Creative Labs has some good USB Sound Cards that you just plug in and then hook up external speakers or headphones. Excuse this post if I'm way off base with this.