View Full Version : [ubuntu] no speaker & no mic

August 7th, 2010, 08:59 PM
headphones do produce sound, however.
I have this problem since ever (all the way from 32b ubuntu 6 up to my 64b Lucid Lynx 10.04, kernel 2.6.32-24). I use a lg laptop, model p1, encoder is alc883, soundcard intel-hda, 5.1ch...

fixed the user groups, set everything on alsamixer to be reasonable (Master - max, headphones-on, speaker -max, pcm - max, front - max, front mic - max, front mic boost- min, line-max, mic-max, mic-boost-min, spdif -on, spdif def. pcm - on, beep - max,caller id-max, off-hook - max), connector in the volume tool set to analog speaker, I tried many of the models in alsa-base.conf's last line (options snd-hda-intel=...). if I had an easy option to brute-force (without having to restart), I would have tried them all.

ideas anyone?

August 9th, 2010, 06:12 PM
i fixed my no mic problem by installing "linux-backports-modules-alsa-lucid-generic"

August 10th, 2010, 06:27 AM
thanks. no change, though.

August 10th, 2010, 04:31 PM
Having the same problem: Sound over headphones but not speakers.

Here's the relevant output from lspci -v:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Hewlett-Packard Company Device 1484
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at d4500000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Capabilities: [130] Root Complex Link <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intelFrom alsamixer:

Card: HDA Intel F1: Help │
│ Chip: Intel G45 DEVCTG F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: Master [dB gain: -0.75, -0.75] Esc: Exit │

The CREATIVE webcam microphone works if selected from panel "Sound preferences," but the internal mic doesn't work at all.

September 3rd, 2010, 01:48 AM

September 3rd, 2010, 05:26 AM

Can you remove alsa-backports, reboot, and run this command please.

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Enter your user password when prompted. Choose the upload option and provide a link for the output.

September 4th, 2010, 10:30 PM
thanks for answering!
here's the link:

September 5th, 2010, 06:08 AM
Whatever it is that you added to alsa-base.conf, please remove it and reboot. Now post the output of these commands:

sudo dmidecode -t bios
sudo dmidecode -t baseboard

September 5th, 2010, 07:04 AM
# dmidecode 2.9
SMBIOS 2.4 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: Phoenix Technologies LTD
Version: RKYWSF27
Release Date: 01/25/2007
Address: 0xE4AF0
Runtime Size: 111888 bytes
ROM Size: 1024 kB
ISA is supported
PCI is supported
PC Card (PCMCIA) is supported
PNP is supported
BIOS is upgradeable
BIOS shadowing is allowed
ESCD support is available
Boot from CD is supported
Selectable boot is supported
EDD is supported
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported

# dmidecode 2.9
SMBIOS 2.4 present.

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
Manufacturer: LG Electronics
Product Name: ROCKY
Version: Not Applicable
Serial Number: Not Applicable

Handle 0x0008, DMI type 10, 6 bytes
On Board Device Information
Type: Sound
Status: Disabled
Description: HD-Audio

September 5th, 2010, 09:06 AM
If you are able to update your bios, please do so.
Also post an updated alsa-info text.

September 5th, 2010, 07:41 PM
unfortunately LG doesn't publish official updates for my bios, and did not reply to a few requests by me over the years. there is some unofficial stuff over the net, but I'm not sure it is a good idea to use it.

anyway, the new alsa-info is in:

thanks again.

September 5th, 2010, 07:56 PM
Go into your bios setup and make sure your onboard HD audio is enabled:

Type: Sound
Status: Disabled
Description: HD-Audio
Following step is an alsa upgrade. Use the link in my sig

September 5th, 2010, 08:33 PM
no such option (or anything that seems relevant) in the bios. but I don't think that this is really the point, since the sound card does work - only the speakers and the mic fail.

September 6th, 2010, 07:08 AM
Did you try the alsa upgrade?

September 6th, 2010, 07:42 AM
yes. didn't change anything.

September 6th, 2010, 08:00 AM
What are the onboard options in bios?

September 7th, 2010, 08:25 PM
As I said, no relevant entry in the bios. here's my entire bios menu:

System time & date ...
Pri. Master [cd-rom]
Sec. Master [120GB SATA]
Legacy USB support [enabled]
Boot time diagnostic screen [enabled]
Core multi-processing [enabled]
virtualization technology [enabled]
SATA controller mode [enabled]
AHCI configuration [enabled]
CPU deeper sleep [supported]
Battery charge stop percentage [standard]
Battery fast charge [disabled]
fan mode control [on]
Silent mode in AC [normal]
Silent mode in DC [normal]
Fn key setup [5 sec.]
Wake on lan [disabled]
PXE/Remote boot OPROM [disabled]
PCIE device wake up [enabled]
SIO control:
Serial port A: [auto]
Parallel port [enabled]
mode [ECP]
Base I/O address [378]
Interrupt [IRQ 5]
DMA channel [DMA 1]
some password options....
Boot priority order...
Exit with/without save, load defaults....

August 6th, 2011, 08:50 PM