PDA

View Full Version : [SOLVED] 10.04 Sound error, buttons control master anc pcm



x C0MMAND0 x
August 5th, 2010, 06:53 PM
So, when my volume is around or below "15%" (by visually estimating the volume slider), it cuts out and there no sound, but it isn't muted. Here is what I did. I ran Alsamixer and then used my volume buttons on my laptop (Dell XPS M1330) and watched what happened. First, the PCM increases all the way until it is at 100%, and THEN the Master volume starts increasing afterwards and I can hear the sound.

I need to get this issue fixed as the minimum volume is still fairly loud. Manually adjusting Alsamixer to have Master at 100% and then adjusting PCM level gave me fine control and appeared to function properly.

So, how do I make it so the volume buttons on my laptop only control the PCM level, and then I can set the master to be 100% all the time...or is that a bad workaround for a deeper problem?

lidex
August 7th, 2010, 04:43 AM
Go to this page:
https://wiki.ubuntu.com/DebuggingSoundProblems/KarmicCaveats
The 'volume range anomalies' section

uylug
August 7th, 2010, 04:45 AM
My Ubuntu does something weird too :p

By decreasing the sound from 100% to 80% you can not hear it anymore. Its like it changes a lot faster when its closer to 100%

x C0MMAND0 x
August 11th, 2010, 03:55 PM
Go to this page:
https://wiki.ubuntu.com/DebuggingSoundProblems/KarmicCaveats
The 'volume range anomalies' section

Thank you, this fix worked from the post.

x C0MMAND0 x
August 11th, 2010, 04:45 PM
I have a new issue now. I have it so my volume buttons control the PCM, which is what I want. But, I need the master to ALWAYS be set to 100%. When I reboot, the Master volume is not at 100% by default. How do I change/set it so that the master will always be at 100%?

lidex
August 12th, 2010, 12:00 AM
I have a new issue now. I have it so my volume buttons control the PCM, which is what I want. But, I need the master to ALWAYS be set to 100%. When I reboot, the Master volume is not at 100% by default. How do I change/set it so that the master will always be at 100%?

Have a look here:
http://ubuntuforums.org/showthread.php?t=1393319

x C0MMAND0 x
August 12th, 2010, 05:06 PM
Have a look here:
http://ubuntuforums.org/showthread.php?t=1393319

Excellent. Thank you for the assistance, worked perfectly just commenting out that line from post #5 I believe.