View Full Version : [SOLVED] Touchpad doesnt work with ubuntu; Help !

August 3rd, 2010, 09:03 PM
I just installed ubuntu v10.04 yesterday as a dual boot; but the touchpad hasn't worked at all with ubuntu. I had to TAB to select my options to install it. The mouse is just frozzen. The mouse work perfectly with Windows 7.. Im obviously not computer literate just wanted linux because coworker recommended it over Micosoft.

Computer Specs: Sony laptop, 4gb ram, 2.10 GHz, 500gb HD.

a million thanks for helping :KS

August 4th, 2010, 10:01 AM
There's a blog post here: http://uri.tl/s which details how to install Ubuntu 10.04 on a Sony Vaio, and have the touchpad working.

Hope it helps.

August 4th, 2010, 05:52 PM
Get a external mouse and go to System>Administration>Hardware Drivers. Install drivers for your trackpad and restart.

August 25th, 2010, 11:46 PM
Threads merged, duplicate removed, formatting normalized.
Please review the Code of Conduct:
# Please use color and font properties for highlighting portions of your text, and not for all of the text in your post.
# Typos and other errors can cause miscommunication between users on the forums, please preview your text before posting.
# Please do not cross post, or post the same thing in multiple locations.

January 9th, 2011, 01:27 AM
I just got the touchpad to work by editing
/etc/default/grub to include GRUB_CMDLINE_LINUX="i8042.nopnp"

sudo update-grub


January 9th, 2011, 01:45 AM
That is great to here! ;) I will note that as a fix for anyone else with a not-working touchpad.