PDA

View Full Version : [ubuntu] 3D games freezing on launch?



sminor13
August 3rd, 2010, 07:33 PM
I just installed Ubuntu 10.04 on my new desktop (Core i7, nVidia GTX260) and installed the nvidia driver by enabling the restricted driver when Ubuntu prompted me to. This allowed me to get Compiz working. However on reboot, the display was fuzzy, which i fixed by following the instructions at
http://www.brighthub.com/hubfolio/tolga-balci/blog/archive/2009/06/09/blurry-fonts-with-nvidia-in-linux.aspx
Then I installed Warsow and Teeworlds to try out some 3D games. However, when I start one of the games, Ubuntu appears to change resolutions and just freezes. I say "appears" because everything looks larger and there are black bars on the sides of my 16:9 display as if it has changed to a low 4:3 resolution; however, my display claims that the signal is still 1920x1080. Ctrl-Alt-Backspace doesnt work (even though I reenabled it)

Here is my xorg.conf:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 260"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0; 1920x1080_60"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Google has let me down on this one. Any help would be greatly appreciated!

bprins
August 10th, 2010, 06:22 PM
re enabled ctrl alt backspace here:
“System”->”Preferences”->”Keyboard”
“Layouts” -> “Layout Options” -> “Key sequence to kill the X server” ?

different way to get out of ur hanging game is ctrl alt f2 to open a terminal, kill -9 yourapp and go back to X.

not that any of that solves your problem, but at least you have some more freedom experimenting to get it working.

those games run in opengl? if not, can you run them in opengl? does that give different results? or trying lower resolutions?

I had similar problems on directX (using wine). My issues were solved by using opengl, and now with wine1.3 nothing bugs.

Sorry for the probably useless post, but that 1% chance that I help you solving the problem forced me to reply :)