View Full Version : [ubuntu] 10.04 partitioning bug

July 27th, 2010, 09:12 PM

MB m2a-vm
HDD: 2 hdd sata 250G each
Ubuntu 10.04 64b downloaded from site
in BIOS ive set sata IDE and ASCI - the same problem...
the hdd are partitioned as follow:
1 hdd : 4g unused space (made it for swp)
26G ntfs
50G ntfs
150G ntfs
2hdd: 230G ntfs

i want to install ubuntu on hdd 1 - 26G partition
now when i start the installer in partitions it shows me serial ata RAID pdc_cbac (stripe) ... 498G. i cant chose from dropdown any of the 2 hdd. when i enter manual partitioning it shows me the partition as i listed them, in a raid volume dev mapper pdc_cbac...

now i disabled 1 hdd in bios (2 one); i checked that is disabled trough a dos boot loader... it is... now when i enter install partition, the disabled hdd its still there and the raid volume same, unchanged.

why is this happening??
why cant i see my 2 hdd in partitioner drop down menu???
how can i install without physically taking out 2-nd hdd??

see the picture; the freespace at the mouse pinter is in fact a ntfs partition on hdd2, hdd that is disabled in bios

July 27th, 2010, 09:16 PM
Try this

July 27th, 2010, 09:31 PM
tried CTRL ALT F2
sudo dmraid -x
it tell me that "raid set deletion is not supported in pdc format"

also a step by step process would be helpful
as i have little knowledge of linux

July 27th, 2010, 09:39 PM
I'm no raid expert but do you have raid setup?

I had the same problem the installer not seeing the drive I wanted to install on

And i fixed it by opening a terminal and doing a
sudo apt-get remove dmraid

Do this before installing when you are just booted into a live cd then try the installer again

July 27th, 2010, 10:42 PM
im having 2dd in ahci; no raid; tried ide its the same; 1 of hdd ts disabled in bios, cant see it in boot menu;

sudo apt-get remove dmraid

worked 4 a moment i could see my sda drives but i could also see the raid volumes and the disabled sda (the second hdd)
it gave me an error at 5% - "The ext 4 file system in partition #2 of SCSI (0,0,0)(sda) failed"

how is this possible????? does ubuntu reads through BIOS?????? how can it read the disabled sda????

ps: the install stopped ath the phrase : "the installation will finish soon. we hope you enjoy ubuntu" :D that is funny;

July 28th, 2010, 05:36 AM
If a drive was ever in RAID (check BIOS some systems are or were), it saves metadata.

DO NOT run if you have RAID and want to keep it.
Presence1960 on remove old raid setting from HD
sudo dmraid -E -r /dev/sda
sudo dmraid -E -r /dev/sdb
Also check BIOS for raid settings
More discussion:

July 28th, 2010, 11:03 AM
i had them in raid before; ive tried to install ubuntu in raid and it messed my partitions i could see them in linux - systemrescuecd - but not in windows; anw ive made a buckup and repartitioned both hdd (ahci bios) in windows; and reformat full...; kind of strange there is anything left behind;

ive read the indicated post and i think ill pass this distro of ubuntu; its not safe for the data i have on drives at the moment

thx for help

July 28th, 2010, 01:58 PM
oldfred decided to give it another try
so ive read again presence1960 (http://ubuntuforums.org/member.php?u=657448)'s post and made

sudo dmraid -E -r /dev/name_of_your_disk
on both hdd fom ubuntu live cd; restarted; installer works fine this time; the data i had its still there;

thx again