View Full Version : Spreadsheet::Read error messages

July 26th, 2010, 09:01 AM

I installed Spreadsheet::Read via cpan. I tried that out; that didn't work. I thought Ubuntu 9.10 may not like my cpan install, I then installed what I thought were equivalent modules via synaptic. These were the two that I thought were equivalent: libspreadsheet-parseexcel-perl, and libspreadsheet-writeexcel-perl.

It appears to me now that the parseexcel is a different product from Spreadsheet::Read. The parseexcel is a slight improvement -- I am still getting the error messages; but parseexcel produces a parsed output.

Can someone pls tell me what these error messages are, and how I may get rid of them:

"Use of uninitialized value $iSheet in array element at /usr/local/share/perl/5.10.0/Spreadsheet/ParseExcel.pm line 1705"

Alternatively, can someone point me a forum or support group for these products. I tried googling, but all I got was the author's email address.

The spreadsheet I am using has two worksheets: OGC, IAU. This was originally an MS excel spreadsheet, but I got gnumeric to save it in excel 5.0 format in my ubuntu 9.10.


July 26th, 2010, 11:06 PM
You should get better help here, that buried in ABT.