View Full Version : [ubuntu] Panel has solid color background under the main menus and tray icons

July 19th, 2010, 09:56 PM
That's about it.

It seems to me a very simple problem to solve, but couldn't find the answer anywhere.

We all know that opening the "Panel Properties" window, on the "Background" tab, we can choose a background image, a solid (or transparent) colour or just leave it at the theme's default.

What happens is that under the main menu (Applications - Places - System) and under the tray icons the background is always the theme default, no mater what I have chosen on the Panel Properties window. The rest of the panel changes the background as I want.

So, what to do to make these parts of the panel to "obey"?


July 20th, 2010, 12:44 AM
I've never been able to get gnome-panel transparency to work properly either. A program called AWN (apt:avant-window-navigator) can act as a panel and properly supports transparency (it is a bit more resource intensive though).

July 20th, 2010, 04:07 AM
I know AWN, but I don't want that much resources, it's just the main Ubuntu panel that I want to let entirely transparent. I believe there should be a simple way to make this.

July 20th, 2010, 03:53 PM
The color it is keeping under the main menu, applets, tray and window list (on the other default panel on bottom of the screen) is the same as the "Windows" color set in the customize theme window, in appearence preferences.

I want to change the color from those parts. Anyone?

August 13th, 2010, 07:54 PM
Sorry for bumping an old topic but this has always bugged me! :-x

August 13th, 2010, 09:00 PM
I sort of fixed it for me, but don't know how.

What I can say is that I was just messing with the themes options and also with gnome color chooser and sometimes the panel would behave as you want and sometimes it would ignore your settings.

August 13th, 2010, 11:18 PM
Sorry for bumping an old topic but this has always bugged me! :-x

Try this fix... http://ubuntuforums.org/showpost.php?p=9629583&postcount=5 (http://ubuntuforums.org/showpost.php?p=9629583&postcount=5)

August 13th, 2010, 11:23 PM
That worked stinkeye. Thank you very much. I've been trying to find that silly workaround for a while now.