View Full Version : [ubuntu] Custom .Xsession behaviour not normal

July 19th, 2010, 08:45 PM
My problem is, when I start my custom xsession through startx I get almost ideal results; the network manager requires a password every time. But when it is run through gdm I cannot use any of the awesome3 hotkeys (and so alas, cannot actually do _anything_) although the wireless does connect automatically (?).

Any help would be appreciated, let me know if you need any more things for debugging.


#!/usr/bin/env bash
xsetroot -solid black &
gnome-settings-daemon &
# gnome-power-manager &
# gnome-panel &
stalonetray &
nm-applet &
exec /usr/bin/awesome

-rwxr-xr-x 1 steve steve 156 2010-07-19 20:10 .xinitrc
lrwxrwxrwx 1 steve steve 8 2010-07-19 19:31 .Xsession -> .xinitrc

[Desktop Entry]
# The names/descriptions should really be better
Name=Custom Session
Comment=This starts a custom session
# The "default" Exec is a very special one and is handled specially in
# the Xsession script, you could also have "custom" which would just run
# "~/.xsession" directly

July 20th, 2010, 02:57 AM
Perhaps I don't understand, but is your goal to not have to enter a keyring password to have your network just work when you login? If so I got around this once by just setting the keyring password to be blank. Not very secure.

Sorry if I misread what you are trying to do.

July 20th, 2010, 12:15 PM
My goal is that when I use the "custom" option in gdm to have the behaviour that happens when i run "startx," currently the "custom" option is very buggy (can't use any hotkeys or open any menu's).