View Full Version : [ubuntu] Misssing Desktop Icons

Jesse Brent Coats
July 18th, 2010, 09:08 PM
When I start my system, no desktop icons show up, even though I have Icons in my ~/Desktop directory. Any ideas why they aren't showing up?

July 19th, 2010, 07:41 AM
Try this :- press alt+f2 and type "dbus-launch nautilus" .

Jesse Brent Coats
July 19th, 2010, 12:55 PM
I've tried that, but it only opens a file browser window. No icons appear on the desktop.

July 19th, 2010, 07:40 PM
I've tried that, but it only opens a file browser window. No icons appear on the desktop.

Don't worry, try this:

Press Alt+F2 then type gconf-editor to open the configuration editor.
Now, Goto Apps->Nautilus->Desktop.
Check the three options - computer_icon_visible, home_icon_visible, volumes_visible.
Close the configuration window.

Hope this helps.

July 21st, 2010, 03:04 AM
I've got the same problem, and neither suggestion above made any difference. No icons of any sort show on my desktop, but if I browse the desktop folder in Nautilus the files and icons are all still there. Any ideas anyone? Thanks!

July 24th, 2010, 04:50 AM
I figured out how to fix mine. The ATI display drivers seem to have gotten "confused" by my having attached an external display and having changed resolution settings to accomodate it. If I started System>Preferences>Monitors, it showed my screen as pushed to the right and extening off the visible area. Apparently all my icons were in that invisible part. By going into the ATI Catalyst Control Center and changing the settings in the display manager tab to single display, then changing the resolution to a lower value, and then changing the resolution back to its proper setting, all seems to be fixed (knock on wood)...

July 24th, 2010, 07:25 AM
After a recent update and change of monitor this has also happened to me.

Only thing that has worked so far is to type 'killall nautilus' into a terminal but on a reboot the same problem reappears.

Is there a permanent solution?


July 24th, 2010, 08:19 AM
No, what's confusing is the way the ATI chip and Ubuntu work togerher when you have an external display set up. If you follow these steps everything should work out fine ... for those of you who have this problem with additional external displays (on a laptop):


Make sure that you have both displays set up to be working and use the Ubuntu monitors settings as opposed to Catalyst or whatever control center you've been using. The Ubuntu monitors settings are located at ----> START ----> SYSTEM ----> PREFERENCES
Look for ... MONITORS

If this solved the problem of the person who started this thread please mark it as solved under the thread tools.