View Full Version : [gnome] ~/.XCompose ignored ?

July 17th, 2010, 12:23 AM
I'm trying to play with compose key to add symbols for math and logic. Presently, I have created a new file ~/.XCompose, and in that file is

1 include "%L"
3 <Multi_key> <a> <asciitilde> : "∝" U221D

I can use the compose key to input defaults like ə,, and , so I know thats working.

I've rebooted the machine, but only the default compose key bindings seem to exist.

I have to admit I borrowed this file from a co-worker, I'd ask him but hes not around at the moment.

July 28th, 2010, 11:20 PM
ok, went back to try to get this to work again. this time I tried adding custom lines directly to /usr/share/X11/locale/en_US.UTF-8/Compose, to no avail.

I just added the line

<Multi_key> <E> <E> : "∃" U2203

at the end of the file, but it did noting ( control+shift+e+e does nothing ).

I tried this modification with and without the ~/.XCompose present. Neither time worked.

each time I make a modification I log off and then on again.

July 28th, 2010, 11:23 PM
I perhaps should also note that metacity stopped starting up automatically for me so I manually added it to the startup applications.

I don't know if this is even remotely related.

July 30th, 2010, 11:41 PM
so.. whats going on here ? modifications to both the main config file as well as the ~/.XCompose do nothing.

am I missing something obvious ?
am I formatting the files incorrectly ?
do the files have the wrong name ?
is my computer looking elsewhere for the config settings ?

July 30th, 2010, 11:44 PM
ah, I see
there is a separate compose config file for each possible keyboard layout

so I might be using a nonstandard layout

July 30th, 2010, 11:50 PM
so how do I figure out which compose file to edit ?
I'm using an apple aluminum keyboard, maybe its different for this ?

July 31st, 2010, 12:06 AM
still no luck

July 31st, 2010, 01:05 AM
as usual I am an idiot : I ignored the part of the tutorial that said to set environment variables. it all works fine now ∃∀.

January 8th, 2013, 10:07 PM
So please enlighten a few other idiots. Where is the tutorial? What environment variable to set? Thanks!

April 29th, 2013, 03:45 AM
I think he is talking about this tutorial:

In order to use your own compose key table, you have to modify the file "~/.gnomerc" to include:
export GTK_IM_MODULE="xim"

Now everything works fine for me (13.04). For some reasons, I didn't have to do this modification with the previous version of Ubuntu (12.10).

April 29th, 2013, 04:29 AM
Thread closed. Please do not post in old threads.